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SAFETY WARNINGS
For safe use of Datapaq equipment, always:

 Take care to follow its supplied instructions.
 Observe any warning signs shown on the equipment itself.

Indicates potential hazard.
On Datapaq equipment this normally warns of high 
temperature, but where you see the symbol you should 
consult the manual for further explanation.

Warns of high temperatures.
Where this symbol appears on Datapaq equipment, the 
surface of the equipment may be excessively hot (or 
excessively cold) and may thus cause skin burns.



 European 
 Union 
 Directives

The following product types

XDL12 Thermocouple Data Logger

manufactured by Datapaq Ltd. 
Lothbury House, Cambridge CB5 8PB, UK

comply with the requirements of European Union directives as 
follows.

Directive 2004/108/EC Electromagnetic Compatibility (EMC) 
Standards Applied 

EN61326-1: 2006 – Group 1, Class B equipment (emissions section 
only), and Industrial Location Immunity (immunity section only).
CFR47: 2007 Class A – Code of Federal Regulations: Part 15 
Subpart B, Radio Frequency Devices, Unintentional Radiators.

RoHS Compliance Datapaq temperature monitoring equipment 
is exempt from EU Directive 2002/95/EC (restriction of the use of 
certain hazardous substances in electrical and electronic equipment) 
under category 9 Monitoring and Control Instruments. This Datapaq 
product nevertheless uses RoHS-compliant components and 
manufacturing processes.

 Conforms to relevant South Korean EMC Standards.

Electromagnetic Compatibility Applies to use in 
Korea only. Class A Equipment (Industrial Broadcasting & 
Communication Equipment). This product meets 
requirements for industrial (Class A) electromagnetic 
wave equipment and the seller or user should take notice 
of it. This equipment is intended for use in business 
environments and is not to be used in homes.
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Introduction
Datapaq ® Tracker systems, incorporating Insight™ software, are a complete 
solution for monitoring and analyzing the performance of your heat-treatment 
process – the temperature profiles of products within it, and the performance 
of the furnace itself; accurate data acquisition and powerful analysis techniques 
are combined with flexibility and ease of use. The Tracker system’s power and 
flexibility make it a perfect tool for process-temperature monitoring, from 
commissioning and troubleshooting to process optimization, ensuring consistent 
quality of product and maximum efficiency.

Current temperature characteristics can quickly be compared with previously 
stored reference curves to detect operating abnormalities – and innovative 
analysis techniques help in identifying problems, fine-tuning the process and 
reducing running costs.

A powerful and flexible printing option allows the user to generate and 
customize reports, including any or all of the analysis results or raw 
temperature data.

The XDL12 logger has scope for wide application in heat-treatment processes 
and is specifically designed for location outside the high-temperature 
environment while monitoring and analyzing data in real time from 
thermocouples placed inside the furnace. It is particularly suitable for use with 
Datapaq Insight Furnace Surveying software, for assessing a furnace’s 
accuracy and uniformity of heating and its compliance with the AMS 2750D or 
other standards.

Hardware for a basic system using the Datapaq XDL12 data logger comprises:
 Data logger (including communications lead and charger) (p. 9).
 Thermocouple probes (for specifications, see p. 11; for usage, see the 
relevant manual supplied with your system).

This manual is for Datapaq systems supplied with an XDL12 data logger, and 
focuses on all aspects of using the logger. There is also guidance on setting up 
the Insight software; complete information on using Insight – both Furnace 
Tracker and Furnace Surveying – is contained in the online Help system 
available when it is installed. For step-by-step instruction on how to use the 
logger and other system hardware components to collect temperature data 
during your process, see the dedicated system manual supplied.



Users of Furnace Surveying will use this manual chiefly to gain familiarity with 
the basic operation of the XDL12 logger. For use of the Furnace Surveying 

software and the procedure of carrying out a temperature uniformity survey, users 
will need to refer to the Furnace Surveying User Manual and – especially – 

the Furnace Surveying software’s Help system.
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Logger Specifications and 
Operation
The XDL12 data logger is at home in a wide range of heat-treatment 
applications where a logger is required to operate outside the high-temperature 
environment. The XDL12’s capacity for 18,000 data readings over each of 12 
data channels makes it a supremely powerful, accurate and in-depth data-
collection tool. Its capability for hardwired telemetry, in conjunction with 
Datapaq Insight software, allows temperature profiles to be watched developing 
– and be analyzed – in real time. A single instance of Insight will simultaneously 
support up to three XDL12 loggers collecting data by hardwired telemetry, 
allowing data from 36 channels to be gathered.

The XDL12 data logger. Thermocouple sockets are on the rear of the unit.

The logger’s key features are:
 Twelve thermocouple channels for maximum data collection on each run.
 Individual loggers can be supplied with combinations of different 
thermocouple types (see specifications, below).
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 Huge memory capacity: 18,000 data points on each channel for detailed 
process analysis.

 High accuracy: ±0.3°C/0.5°F (with type K thermocouples) for compliance to 
tight specifications.

 Hot data protected by non-volatile memory or software warning if reset is 
attempted before download.

 USB communication capability.
 Hardwired telemetry for monitoring in real time with full analysis functions 
and alarms to warn the user if the process is out of specification.

 Capability for up to three XDL12 loggers to gather data by hardwired 
telemetry simultaneously.

 Four LEDs to show the exact status of the logger’s activity and its batteries.
 Start and stop buttons for easy user control.
 Powered by rechargeable NiMH batteries.
 Rugged case and electronics allow operation in dusty environments.
 Proof against data-corruption from earth-loop problems.
 Lightweight and portable.

Specifications
Each XDL12 logger is supplied to order, with combinations of up to three 
different thermocouple types as required by the user (see below). For example, 
there may be a need for nine type K or type N thermocouples (for furnace 
measurements on a surveying jig) combined with three type R or type S 
thermocouples (for control measurements).

Length (inc. handle) 340 mm/13.4 in.
Width 330 mm/13.0 in.
Height With computer rest: 80 mm/3.1 in.  

Without computer rest: 60 mm/2.4 in.
Weight 6.5 kg/14.3 lb
Thermocouples Combination of up to three possible types, according to model 

of logger supplied: J, K, N, R, S, T; see below for data. 
Thermocouple sockets accept both standard and miniature 
thermocouple plugs.

Operating temperature 0–55°C/32–131°F
Humidity range 0–85% non-condensing
Ingress protection IP50 (dust-resistant)
Real-time monitoring Hardwired telemetry via communications lead as standard. 

Capability for up to three XDL12 loggers to gather data by 
hardwired telemetry simultaneously.

Sample interval 1 s to 50 min. in 1-s increments



Data storage 18,000 data-points per channel
Data-collection start Start button, Temperature rise, Temperature fall, Date/time
Pre-trigger data stored Yes (configurable; see p. 28)
Hot-data protection By non-volatile memory, and software warning if reset attempted 

before download
Communications USB
PC/software compatibility See p. 19
Logger reset Possible after download by start button (using previous run 

parameters)
Battery Datapaq NiMH rechargeable battery-pack + lithium AA
Battery life Over 60 hrs continuous use (see p. 13), depending on sample 

interval and operating temperature
Battery charger All regions except Americas – CH0070 

Americas – CH0075

Specifications for Specific Thermocouple Types

Type J Type K Type N

Normal 
range
Accuracy *

0°C to 800°C 
32°F to 1,472°F
±0.3°C 
±0.5°F

−100°C to 1,370°C 
−180°F to 2,498°F
±0.3°C 
±0.5°F

−100°C to 1,300°C 
−180°F to 2,372°F
±0.4°C 
±0.7°F

Lower range 

Accuracy *

– 

–

−190°C to −100°C 
−310°F to −180°F
±0.5°C 
±0.9°F

−190°C to −100°C 
−310°F to −180°F
±0.5°C 
±0.9°F

Resolution 0.1°C/0.2°F 0.1°C/0.2°F 0.1°C/0.2°F

Socket color 
(IEC 584)

Black Green Pink

Type R Type S Type T

Normal 
range
Accuracy  *

50°C to 1,760°C 
122°F to 3,200°F
±1.1°C 
±2.0°F

50°C to 1,760°C 
122°F to 3,200°F
±1.1°C 
±2.0°F

−100°C to 400°C 
−180°F to 752°F
±0.3°C 
±0.5°F

Lower range 

Accuracy  *

−40°C to 50°C 
−40°F to 122°F
±1.8°C 
±3.2°F

−40°C to 50°C 
−40°F to 122°F
±1.7°C 
±3.1°F

−196°C to −100°C 
−321°F to −180°F
±0.5°C 
±0.9°F

Resolution 0.1°C/0.2°F 0.1°C/0.2°F 0.1°C/0.2°F

Socket color 
(IEC 584)

Orange Orange Brown

* Using sample interval > 0.8 s over temperature range shown. For more details, contact Datapaq.
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Due to continuing product development, specifications are subject to change 
without notice.

Stop/Start Button Actions

Action Results Notes 

Press GREEN button. Starts logging. In telemetry mode, also starts sending data. 

Press RED button. Stops logging. Data retained in memory. Logger cannot be re started 
until data downloaded. Red LED flashes every 5 s to 
warn of data in memory. If in telemetry mode will 
also send ‘end of run’ signal to end real-time run. 

Press GREEN and RED 
buttons together, and 
hold for 3 seconds. 

Turns logger 
off. 

Data retained in memory. 

Press GREEN button 
after downloading data. 

Starts logging. Last re-set conditions (sampling interval, probe 
selection, etc.) used as default. 

Logger LEDs
The logger is equipped with two sets of LEDs: two LEDs show the status of the 
battery, and two show the status of the logger and its memory.

Battery Status LEDs

Yellow Red Meaning

Flashing every 
5 seconds

Off Battery is at 20% or less of maximum charge, and charger not 
connected.

On On Battery on fast charge.

On Off Fast charge complete, or 
Problem with battery – cannot be charged.

Off Off Charger not connected, and battery at more than 20% of 
maximum charge.

On Flashing once 
per second

Battery being preconditioned due to being too hot, too cold 
or too deeply discharged (see p. 15).

Flashing 
rapidly for 
2 seconds

Off Battery level extremely low. See p. 15.
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Logger Status LEDs

Red Green Meaning

5 flashes, alternating 
with green LED

5 flashes, alternating with 
red LED

Logger successfully reset

Flashing, alternating with 
green LED, at sample 
interval *

Flashing, alternating with red 
LED, at sample interval *

Logger awaiting trigger

On Flashing at sample interval * Logger awaiting trigger but one or 
more thermocouples is open circuit

Flashing together with 
green LED, at sample 
interval *

Flashing together with red 
LED, at sample interval *

All probes are above trigger 
temperature, and thus data-recording 
cannot be triggered by rising 
temperature (or, if falling trigger is set, 
all probes are below trigger point)

Off Flashing at sample interval * Logger acquiring data

Flashes 5 times (once 
per second)

Off Connection between communications 
lead (attached to an active PC) and 
logger has been made

Flashing every second Off Internal error

Flashing every 5 
seconds 

Off Logger has data in memory which has 
not been downloaded

2 quick flashes every 
second

Off Logger too hot to start logging (after 
pressing Start button)

* Flashing interval will actually fall in range 1–5 s.

Battery
The logger uses a pack of three rechargeable 1.2 V nickel-metal-hydride 
(NiMH) cells. Only battery packs supplied by Datapaq are suitable.

Service life of the rechargeable NiMH battery is about three years or 1,000 
charge/discharge cycles. The logger must be returned to Datapaq for battery 
replacement.

For subsidiary power, the logger also contains a lithium AA battery. This will 
normally last for the life of the logger, but, if replacement is needed, the logger 
must be returned to Datapaq.

Battery Life

Battery life (discharge time) of NiMH rechargeable batteries is affected by the 
following factors.
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 Operating Temperature – Essentially, the higher the ambient 
temperature the battery operates in, the shorter will be the life. Batteries 
that operate for a large part of the process cycle at relatively low 
temperatures will have a longer life than those that operate for the majority 
of the process cycle at higher temperatures.

 Sample Interval – The shorter the sample interval, the shorter will be the 
battery life. This is because power is being consumed each time the logger 
takes a reading. A short sample interval will achieve the maximum amount 
of information, but this must be balanced against the greater battery charge 
required.

 Programming and Downloading the Data – When these operations 
are carried out it is necessary to connect to the computer via a 
communications cable, and power is consumed as soon as the cable is 
plugged into the logger. The software warns the user to disconnect from 
the PC, but if the logger is left connected this will affect battery life.

Given the factors that can affect the life of a battery it is obviously difficult to 
predict accurately, but a fully-charged battery can typically achieve over 
60 hours of data-collection using a 30-second sample interval. The LEDs on the 
logger will give the best indication of when the battery is low. In the user’s own 
conditions, experience will quickly indicate typical battery life, and a log should 
be kept for the first few runs, noting sample interval.

Sample Interval No. of Channels Battery Life (hrs) 

1 s 12 30

5 s or more 12 60

Charging

Recharge the battery as follows.
1. Plug the charger into the electricity supply.
2. Plug the charger lead into the charger socket on the logger.

A full charge is delivered in about 2 hours. Indication of battery/charging status 
is provided by colored LEDs on the logger (see p. XX).

14 Specifications and Operation DATAPAQ XDL12



The logger intelligently monitors the battery, ensuring it is never overcharged. 
Thus, by leaving the charger connected to the logger, the logger will always be on 

charge and ready for use. This will not damage the battery or reduce its service life. 

If the logger’s battery is low when the logger is required quickly, it can be 
connected to the electricity supply via the charger and used immediately. The 

battery will then charge while the logger is running. However, to ensure the highest 
level of accuracy, it is recommended that the logger is not connected to mains 

electricity during data-collection (see p. 16).

New batteries – or ones which have been unused for several months – 
should be charged for 24 hours before use.

NiMH batteries discharge slowly even when not in use and will need 
charging if left for more than three weeks.

If the logger is not in regular use, the battery should be charged at least 
every 3 months. If this is not done, the battery may drain to a level where it 

cannot successfully be recharged.

Where batteries are too cold (below 0°C/32°F), too hot (over 45°C/113°F) or 
too deeply discharged, they must be pre-conditioned before fast charging can 
begin. Pre-conditioning (slow charging) occurs automatically if it is required, and 
is shown by the battery status LEDs (steady yellow + flashing red). If the 
battery is still being pre-conditioned after 5 hours, there may be a fault; contact 
Datapaq.

In extreme cases of low battery charge, the logger may not operate at all 
(yellow LED will flash rapidly for 2 seconds). If this happens:
1. Disconnect the communications lead from the logger.
2. Turn the logger off (press green and red buttons together, and hold for 

3 seconds).
3. Connect the charger.
The logger should then operate normally while recharging – though pre-
conditioning may be necessary, as above.

Low Battery Level

When the battery’s charge drops to 20% of the full level, this will be shown by 
the logger LEDs (p. 12) and (if connected to the PC) by the Insight software.
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Auto Power-off

When the logger contains data from a previous run which has not been 
downloaded, or is indicating an error, the logger-status red LED will be flashing. 
If the logger is left in this state there is potential for the battery to flatten, and 
the logger will therefore power-off automatically after five minutes. On 
subsequent power-up, the logger will either return to its pre-power-off state 
or, if the communications lead is connected, be ready to communicate with 
the PC.

Best Practice with the XDL12
The XDL12 is a highly accurate logger which utilizes a specially-designed cold-
junction compensating unit to minimize errors. But note that…

…the following guidelines must be observed to ensure 
maximum accuracy.

Temperature Stabilization

 When carrying out a survey, let the logger stabilize at the ambient 
temperature in the area where it will be used (i.e. near the furnace) for 
1 hour before starting data-collection. This is especially important when 
bringing the logger from an air-conditioned office to a warm workshop, or 
from a warm office to a cool workshop.

 Do not place the logger where there may be sudden temperature 
changes, e.g. where there may be a draught from an opening door or 
where hot air may issue from a furnace.

Powering the Logger

 While a survey is in progress, whenever possible run the logger only 
from its battery – i.e. if it is avoidable, do not use the battery charger as a 
means of powering the logger from mains electricity. A fully-charged battery 
will last at least 60 hours with a sample interval of 30 seconds, and this is 
generally far longer than is required for a survey.

Using and Connecting Thermocouples

 For ease of use, the XDL12 utilizes standard thermocouple sockets. To 
ensure the highest accuracy, extension cables and compensating cables 
supplied by Datapaq have plugs from the same manufacturer as the sockets. 
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If providing your own connecting cables, make every effort to ensure that 
all cables and terminating plugs are from the same manufacturer.

 The XDL12 will accept sub-miniature thermocouple plugs, but for highest 
accuracy standard plugs are recommended.

 Use high-quality extension cables and compensating cables from 
the logger to the external furnace connection, preferably from the same 
batch.

 If using type-R or type-S noble-metal thermocouples, compensation cable 
can be used, but only noble-metal wire will ensure full accuracy. This 
is particularly important if significant temperature variation may occur down 
the length of the cable.

 When using mineral-insulated thermocouples in a vacuum furnace at 
relatively high temperatures, ensure that the diameter of the cable is big 
enough to avoid breakdown of the magnesium oxide insulation but small 
enough to allow the cable to be bent around the test jig. These 
requirements are generally met by 2-mm diameter, type-N, mineral-
insulated thermocouples.

 Minimize the number of plug and socket or other connections in 
the extension cables or compensating cables. In vacuum furnaces and 
autoclaves it is not possible to avoid such connections, but always check the 
condition of the sockets on the inner wall of the furnace, and clean with a 
small-diameter wire brush if oxidized.

 Replace any of the connections on the inner or outer walls of the 
furnace if in poor condition or where the connection seems loose.

Testing and Calibration
It is recommended that the logger is tested and calibrated by Datapaq at least 
once a year. To comply with the AMS 2750D standard, loggers should be 
calibrated every three months. The Datapaq calibration procedure comprises:

 Inspection of the logger, externally and internally.
 Battery- and charge-testing.
 Stability testing, using a stable temperature source and varying ambient 
temperatures.

 Calibration and updating of the logger’s firmware.
 Issue of certificate, which can be traced back to national calibration 
standards.

No other company can offer this degree of in-depth testing as well as a full 
calibration service. To calibrate your logger, please return it to the Service 
Department at Datapaq (see title page for contact details).



It is possible for users to check calibration of the logger themselves if they have 
a secondary standard instrument that complies with the requirements of 
AMS 2750D Table 3.
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Using the Logger with 
Insight Software
See your dedicated system manual for full details on:

 Choosing appropriate thermocouple probes.
 Conducting a temperature-profile run of your process.

Before the logger is used for the first time, you must:
1.  Install Insight software.
2. Establish communication between the logger and the computer/software.

Before each profile run, you will:
3.  Reset the logger to prepare it to receive fresh data.

After the profile run is complete, you will then:
4.  Download the data from the logger.

These stages are described below.

Installing/Removing Insight
Datapaq Insight used with the XDL12 logger requires the following minimum 
computer specification.

 1 GHz processor.
 2 Gb RAM.
 Monitor resolution 1024  768, 256 colors.
 100 Mb free hard disk space.
 DVD drive.
 1 free USB port.
 Microsoft Windows™ XP, Vista, 7, 8 or above.
 Microsoft Internet Explorer 4 or above.

The XDL12 logger operates only with Datapaq Insight v.6.0 and above.
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Installation

Ensure you are logged into Windows in Administrator mode.

For most systems, installation will start automatically on placing the Insight 
DVD in the drive. (If installation does not start, click the Windows Start button 
and select Run; browse to your DVD drive, and run Setup.exe.)

Follow the on-screen instructions. You will need your license number to hand, 
which is to be found on:

 Your license agreement.
 The outside of the DVD case.
 The outside of the system packaging.

Insight’s link with the logger must also be made while Windows is in 
Administrator mode, and it is thus best to do this now, as part of the Insight 
installation: connect the logger to the PC and follow the procedure under 
‘Communications Setup’ (below). Once this has been done, an operator will be 
able to use Insight with the logger connected to the PC without being in 
Administrator mode.

Upgrading

It is not necessary to remove an existing version of the software before 
installing a new one. Settings and data files used with the current installation 
will be maintained.

Removal

From the Windows Start button menu, select Settings and then Control Panel. 
Double-click Add/Remove Programs, select Datapaq Insight and click Add/
Remove.

Using the Software

Full details on using the Insight software are contained entirely within its online 
Help system: access this by clicking Help, and then Contents, on Insight’s main 
menu. Then, within Help, click on Contents headings and topics to expand and 
read them.

You may also click the Help button in any dialog – or press the F1 key – to 
bring up help information relevant to the task being performed.
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Communications Setup
After Insight has been installed, it is necessary to establish communication 
between the data logger and the PC. This will normally happen automatically 
when the logger is plugged into the PC: connect the logger to a free USB port 
and it will be ready to work.

Up to three XDL12 loggers can be connected to the PC simultaneously when 
gathering data by hardwired telemetry (see p. 29).

In case of any problems, note that the process should proceed as follows.

1. Using the communications lead supplied, connect the logger to a free USB 
port on the PC (to minimize communications problems, connect the lead 
first to the PC and then to the logger). The red LED on the logger should 
flash five times to confirm that the connection between the communications 
lead and the logger has been made.
If the PC is having a Datapaq logger connected for the first time, Windows 
will display a ‘Found New Hardware’ message and the PC is then ready to 
work with the logger. If any warnings are displayed about driver-signing, 
confirm them (Datapaq drivers have been tested, and were installed when 
Insight was installed).

Typical sources of problems with establishing communication
 Communications lead not fully inserted – Check correct sockets 
are being used.

 Damaged communications lead or connectors – Check for breaks 
and other damage. Replace the lead.

 Battery not charged – Recharge the battery, ensuring the charging 
LEDs are illuminated (see p. 12).

2. On the Insight software’s menu bar, select Logger > Setup to open the 
Communications Setup dialog.

In order to view the Communications Setup dialog when multiple loggers are to 
be used, each logger must be attached to the PC separately.

3. Click Test.

If the logger is detected, its type and the port to which it is connected are 
displayed.
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SHORTCUT 
Pressing F4 on the keyboard opens the Communications Setup dialog, tests for 

communication with a logger, and displays the logger type and other data 
(equivalent to clicking Test in the dialog).

For more information on the logger in use, click the Diagnostic button which 
now appears. Additional data shown covers firmware version, maximum 
permitted internal logger temperature, battery charge status, serial number and 
temperature recording range. Current temperature of the probes (updated 
once a second) is also shown – or open circuit (*OC*) if no probe is attached; 
the temperature of the thermocouple cold junction is effectively the current 
internal temperature of the logger.

The Communications Setup dialog for the XDL12 logger, with Diagnostic section 
expanded.
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Setting Frequency of Electricity Supply

To increase the efficiency of the logger’s noise rejection, and thereby provide 
more stable measurements, select the frequency of the local electricity supply 
as follows.
1. In the Insight software, select Tools > Options and click on the Logger tab 

and then on the Advanced button.
2. Select 50 or 60 Hz frequency. 50 Hz is most widely used, but 60 Hz is used 

in North America, several countries in South America, and in Japan and 
Korea.

Running a Temperature Profile

A typical use of the XDL12 logger is in carrying out a temperature uniformity 
survey of a furnace to ensure compliance with the AMS 2750D or other 

standards. in this case, temperature profiles (using telemetry or not) will be run 
with Insight Furnace Surveying software using the Temperature Uniformity 

Survey Wizard, and not as described below. To use the wizard, run Insight Furnace 
Surveying and click  – or select Tools > Wizards, or File > New > Temperature 

Uniformity Survey, or Furnace Surveying > Temperature Uniformity Survey.  
With Insight Furnace Surveying, two or three XDL12 loggers can be used 
together in order to gather data from up to 36 data channels simultaneously. 

This is also done using the Temperature Uniformity Survey Wizard. 
For details, see the Furnace Surveying User Manual and the software’s 

Help system.

The remainder of this chapter covers use of the logger with Insight Furnace 
Tracker (not with Furnace Surveying).

Resetting the Data Logger

The data logger needs to be reset, as follows, before it can receive fresh data. 
The following describes a non-telemetry profile run, i.e one during which 
the logger is not connected to the PC, and the data is downloaded to the PC 
afterwards for analysis. (To reset the logger for a run using telemetry, see 
p. 30.)
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It is not necessary to go through the reset procedure if the previous reset options 
are to be re-used: see p. 26.

The procedure described here uses the Insight software’s Logger Reset dialog. If 
you are less sure of the process, you can instead use the Logger Reset Wizard to 

guide you, step-by-step, through this stage of running a profile: click  on the 
Insight toolbar, or select Tools > Wizards from the menu.

Any data stored in the logger but not yet analyzed must be downloaded before 
proceeding, as resetting the logger will permanently erase all data stored in it. If 
the reset process is started on a logger which contains data from a previous run 

which has not been downloaded, a warning message will show this (and the logger-
status red LED will be flashing every 5 s).

1. Use the communications lead supplied to connect the logger to a free USB 
port on the PC. 

To minimize communications problems: a) connect the lead first to the PC and 
then to the logger; b) always use the same USB port – the one which was first 

used to set up communications (p. 21). 

The red LED on the logger should flash five times to confirm that the 
connection between the communications lead and the logger has been made 
(if it does not, see ‘Communications Setup’, p. 21). If the logger is not 
already charged, connect the battery charger lead to the logger.

2. Open the Logger Reset dialog (click  on the Insight toolbar, or press 
function key F2, or select Logger > Reset from the menu bar) and specify 
your reset options.
Sample Interval  Set the time which is to elapse between each set 
(sample) of data points (one data point for each probe) that the logger will 
collect. The shorter the sample interval the better you will be able to 
record short-term variations in the temperature regime – but the total 
recording time available will be reduced, data will take longer to download 
to the PC after a run, and battery life could be shortened so much that it 
will not be enough for a particularly long process. For longer processes, a 
rule of thumb is to set sample interval at 1 minute per day of operation, e.g. 
use 3-minute interval for a 3-day process, 15-s interval for a 6-hour process.

Probes Selected  To exclude them from the temperature profile, click 
on the relevant buttons to deselect those probes which will not be used. 
The thermocouple type of each probe and its socket color are shown. Probe 
1 must always be one of those selected.

Telemetry  Select ‘No Telemetry’.
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The Reset dialog for the XDL12 logger.

Memory Calculator  Calculates the maximum time for which the logger 
can collect data, given the sample interval and the logger’s memory size. 
The time available may be further limited by the level of battery charge.

Battery Status  The charge indicator gives both the current percentage 
of full charge held by the logger battery, and a color-coded report:

GREEN Sufficient charge to perform a run.
YELLOW May be enough charge for a run, but battery getting low.
RED Insufficient battery charge: recharge immediately.

The battery charge level will not be displayed if the logger is on charge: disconnect 
the charger to verify battery status.

NiMH batteries discharge slowly even when not in use and will need 
charging if left for more than three weeks.
If in any doubt, abort the procedure by clicking ‘Cancel’, and recharge the 
logger.
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Trigger Mode  Select here a means to start the logger recording data.
Start Button  After reset, data-recording starts when the logger’s green 

start button is pressed and held for 1 second.
Date and Time  Data recording starts at a specified date and time. The 

current date appears by default.
Rising Temperature  Data-recording starts when the temperature of any 

probe rises to the specified value.
Falling Temperature  Data-recording starts when the temperature of probe 

no. 1 reaches the specified value as it is falling.

3. After clicking OK, the logger is reset and a message box confirms the 
sample interval and trigger mode you have set.

Using Previous Reset Options

The XDL12 retains the last-programmed set of reset options. Thus it is not 
necessary to go through the reset procedure if the same reset options are to 
be re-used. Instead, simply press the Start button to start data-collection with 
the same reset options as before (if trigger mode was set to date and time, 
logging will nevertheless start immediately). Temperature data which is still held 
in the logger and which has been downloaded will then be overwritten (if the 
logger contains data which has not been downloaded, a run cannot be carried 
out unless the data is downloaded or the reset procedure is performed).

Previous reset options are lost if the battery is removed. When it is replaced, the 
default reset options are: 1-s sample interval, all channels selected, start button as 

trigger mode.

Downloading Data

If data acquisition has to be stopped manually, press and hold the logger’s red 
stop button until the red and green logger-status LEDs are on simultaneously. 
A red logger-status LED flashing every 5 seconds indicates data stored in the 
logger but not yet downloaded to the PC.

The procedure described here uses the Insight software’s Logger Download dialog. 
If you are less sure of the process, you can instead use the Logger Download 

Wizard to guide you, step-by-step, through this stage of running a profile: click  
on the Insight toolbar, or select Tools > Wizards from the menu.

1. If not already attached, connect the logger to the PC with the 
communications lead. The red LED on the logger should flash five times to 



confirm that the connection between the communications lead and the 
logger has been made.

2. Open the Logger Download dialog (click  on the toolbar, or press 
function key F3, or select Logger > Download from the menu bar) and wait 
while the data is downloaded to the PC. For an explanation of any error 
messages generated during this process, see p. 33.

A warning message will be shown if the logger has stopped recording data due to a 
discharged battery. Data recorded up to that point will have been preserved. 

3. The Select Process dialog then appears in order that you may choose a 
process file to apply to the results. If the process file and its components 
have been given names, these are shown when the process file is selected. 
Click ‘No Process’ if you do not want to apply a process file.

If you will normally not wish to apply a process file to the results, you can opt not 
to have the Select Process dialog displayed immediately after a download (from the 

menu bar, select Tools > Options > Process File); a process file may still be  
applied subsequently.

4. The newly downloaded data then appears on screen and can be displayed 
(numerically and graphically), analyzed and printed as you wish; see Insight’s 
online Help system. Save the data as a ‘paqfile’ (select File > Save or 
Save As).

You can set alarms to be triggered during a logger download, to warn you of 
incomplete data recorded during the profile run due to an empty battery (from 
the menu bar, select Tools > Options > Run Alarms). This will cause the logger 
to shut down, preserving data already gathered.

Specifying Furnace Start

If you have not applied a process file, or if the process file you applied did not 
specify that the furnace start position be adjusted, you may want to adjust it 
now: from the menu bar, select Process > Adjust Furnace Start, or use the 
right-click menu.

This can be valuable as it permits different paqfiles, i.e. data from different 
temperature profile runs, to be compared with each other. If you do not wish 
to adjust the furnace start at this point, you may still do so at any time 
subsequently.

For an explanation of furnace start, and how to adjust it, click Help in  
the Adjust Furnace Start dialog.
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Logger Defaults and Details
Defaults for several of the logger’s variables can be set using Insight. Select 
Tools > Options > Logger (and click ‘Advanced’ for some features):

 Default number of probes.
 Frequency of the local electricity supply.
 Ability to store pre-trigger data (data recorded before the trigger point 
specified during reset; maximum c. 100 data points).

On this Logger tab of the Global Options dialog you can also find the model 
and identification number of the logger, and enter calibration information 
and be warned when re-calibration is due.

For full details of using the dialog, see Insight’s online Help.

For further features of the Insight software – particularly data analysis and the use 
of process files – see the online Help system (on Insight’s menu bar,  

select Help > Contents).
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Using Hardwired 
Telemetry
In addition to the standard off-line analysis, real-time analysis by hardwired 
telemetry is possible with Insight software when used with an intermittent or 
periodic furnace (a batch process).

Thus, with thermocouples trailing from the furnace and attached to the logger 
outside the furnace, data being gathered by the logger is transmitted via the 
communications lead directly to the PC, and the temperature profile can be 
watched developing in the Insight software as data is received, i.e. in real time.

Telemetry is not available with Insight Lite software.

For processes requiring more than the 12 data channels available with a single 
XDL12 logger, Insight has the capability to gather and analyze data by 
hardwired telemetry from up to three XDL12 loggers simultaneously (see 
below).

Running a Temperature Profile Using 
Hardwired Telemetry

A typical use of the XDL12 logger is in carrying out a temperature uniformity 
survey of a furnace to ensure compliance with the AMS 2750D or other 

standards. in this case, temperature profiles (using telemetry or not) will be run 
with Insight Furnace Surveying software using the Temperature Uniformity 

Survey Wizard, and not as described below. To use the wizard, run Insight Furnace 
Surveying and click  – or select Tools > Wizards, or File > New > Temperature 

Uniformity Survey, or Furnace Surveying > Temperature Uniformity Survey.  
With Insight Furnace Surveying, two or three XDL12 loggers can be used 
together in order to gather data from up to 36 data channels simultaneously. 

This is also done using the Temperature Uniformity Survey Wizard. 
For details, see the Furnace Surveying User Manual and the software’s 

Help system.

The remainder of this chapter covers use of the logger with Insight Furnace 
Tracker (not with Furnace Surveying). By following the procedure in this 
chapter, you will use the Logger Reset and Logger Download dialogs to run a 
temperature profile using hardwired telemetry.
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Running a profile in real time is performed in essentially the same way as a 
normal (non-telemetry) run (see p. 23, and your dedicated system manual), but, 
in addition:

 The communications lead is left attached to the logger.
 A process file can be applied before the run starts in order that the data 
can be understood more readily as it appears on screen (not available with 
Insight Furnace Surveying software).

 While the run is in progress, the real-time display of incoming data can 
be customized as preferred, and the logger’s status can be checked.

Resetting the Logger for a Run Using Hardwired Telemetry

The data logger needs to be reset, as follows, before it can receive fresh data.

The procedure described here uses the Insight software’s Logger Reset dialog.

If you are less sure of the process, you can instead use the Logger Reset Wizard to 
guide you, step-by-step, through this stage of running a profile: click  on the 

Insight toolbar, or select Tools > Wizards from the menu.

Any data stored in the logger but not yet analyzed must be downloaded before 
proceeding, as resetting the logger will permanently erase all data stored in it.

1. Use the appropriate supplied communications lead to connect the logger to 
a free USB port on the PC.

To minimize communications problems: a) connect the lead first to the PC and 
then to the logger; b) always use the same USB port – the one which was first 

used to set up communications (p. 21).

The red LED on the logger should flash five times to confirm that the 
connection between the communications lead and the logger has been made 
(if it does not, see ‘Communications Setup’, p. 21).

2. Open the Logger Reset dialog (click  on the Insight toolbar, or press 
function key F2, or select Logger > Reset from the menu bar), select 
hardwired telemetry, and specify your other reset options (see p. 23).

3. After clicking OK, the logger is reset and a message box confirms the 
sample interval and trigger mode you have set.

4. Leave the communications lead connected to the logger, and click OK.
5. The logger’s red and green status LEDs then briefly flash alternately to 

confirm logger reset; click OK.
6. The Select Process dialog then appears in order that you may choose a 

process file to apply to the results. If the process file and its components 
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have been given names, these are shown when the process file is selected in 
the list. Click ‘No Process’ if you do not want to apply a process file. 
(A process file allows you to see the temperature profile in relation to the 
furnace zones as the profile appears on screen during the run. See the 
Insight software for an introduction to process files: press function key F1, 
or select Help > Contents from the menu bar, and click the section 
‘Process Files: Furnace, Recipe, Product’.)

You may specify that a password is required when an attempt is made to 
close Insight while a real-time telemetry run is in progress: select Tools > 
Options > General from the menu bar.

Real-time Display During the Run

After the first few data packets have been received, the data starts to be 
displayed in the Graph and Analysis Windows, scrolling in real time as new data 
is received. You may change the way the data is displayed with the Axes tab of 
the Graph Options dialog (from the right-click menu, or from the main menu 
select View > Graph Options): under Telemetry, specify how much of the 
recently received data is displayed, and whether you wish to see only a certain 
temperature (y-axis) range, centered on a the latest data.

You may zoom the display as when viewing a paqfile (see the online Help 
system), except that:

 Double-clicking on the graph (or selecting Real Time Zoom from the View 
menu or right-click menu) shows only the most recently received portion of 
the data on the scrolling graph (see above).

 Saved zoom modes are not available.

If the y-axis is not set to be centered (see above), the default y-axis zoom 
changes as more data is received, in order to accommodate all received data.

To move the graph across the viewing area, hold Shift and drag the mouse 
pointer.

You may overlay one or more tolerance/ideal curves on the graph to 
compare with the data as it is being received (select View > Overlay) (not 
available with Insight Furnace Surveying software). Other paqfiles cannot be 
overlaid.

You may adjust the furnace start position while a real-time run is in progress 
(select Process > Adjust Furnace Start, or use the right-click menu).

Calculations shown in the Analysis Window for the chosen data analysis 
mode update continuously as new data is received. As for non-real-time runs, 
calculations are performed only on the currently zoomed area shown on the 
graph. However, if the graph is scrolling and showing just the most recently 
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received portion of the results, the analysis calculations will be performed as if 
on the full zoom view.

If you wish to view another paqfile while the logger is in listen mode, i.e. 
while data is being received and viewed in real time, you must first stop real 
time mode (see ‘Ending the Run’, below).

Ending the Run

To end or pause data-collection while a telemetry run is still in progress, 
select Logger > Stop Real Time Mode. Data then continues to be collected by 
the logger, but it is no longer received in real time by Insight (download from 
the logger after the run is finished to retrieve the full data). The graphical and 
numerical data received up to that point remain on screen, available for viewing 
and analysis, and can be saved as a paqfile.

While the logger is still operating, you may resume the collection of data 
by Insight: select Logger > Logger Listen Mode. This second bout (and any 
subsequent bouts) of data-collection can also be ended and saved as a separate 
paqfile, as above.

If Autosave is enabled (select Tools > Options > General), the data being 
gathered is automatically saved periodically during a telemetry run. If the 
system fails during the run, the last-autosaved version of the data is displayed 
automatically when Insight is next run, and you may then choose to save it as a 
paqfile.

When the run is complete, ensure that data received by Insight has been saved 
as a paqfile. If you wish, you may download the data held in the logger (p. 26), 
though it should normally be adequate simply to save, as a new paqfile, the data 
already received.
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Troubleshooting
Logger Communications Problems

 Communications lead not fully inserted – Check correct sockets are 
being used.

 Damaged communications lead or connectors – Check for breaks 
and other damage; replace the lead.

 Batteries not charged – Recharge the batteries, ensuring the charging 
LEDs are illuminated (see p. 12).

To minimize communications problems:
 Connect the lead first to the PC and then to the logger.
 Always use the same USB port – the one which was first used to set 
up communications (p. 21).

Logger Download Error Messages

Error Message Action

There are 
insufficient readings 
in the logger

Check trigger set point (time or temperature). 
Check logger’s battery for charge. 
Check date/time settings on computer. 
Check probes and their connections. 
Reset logger and test probes (see ‘Logger Diagnostics’, below).

Logger stopped due 
to low battery

Replace or recharge the battery as appropriate, then repeat the 
profile run.

Logger memory full Data collection may have stopped before the run was completed: 
check the data collection period and sample interval before resetting 
the logger for another run (see ‘Resetting the Data Logger’, p. 23).

Checking the Data
Thermocouple probes are generally reliable, but damage resulting from 
inappropriate use or handling can produce erroneous readings. If you suspect 
that invalid data may have been introduced into your temperature profile 
(paqfile), select the View Data tab in the Insight software’s Analysis Window to 
view the raw data as downloaded from the logger. The various types of invalid 
data which may be contained in a paqfile are shown in the analysis grid as 
follows.
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*OC* Open circuit.
*NA* Telemetry data not received.
*LO* Temperature measured was below the range of the logger.
*HI* Temperature measured was above the range of the logger.
*** Calculation cannot be performed (not necessarily because the data are invalid). Does 

not appear in View Data analysis mode.

Probes with an intermittent open circuit may produce spiky, erratic profiles. 
Note that spikes are inevitable when probes are disconnected from a running 
data logger. Typical causes of invalid or interrupted data are:

 Thermocouple becoming detached from the logger.
 Faulty connection.

Readings which are inconsistent with those of other probes may be caused by a 
short circuit (see ‘Logger Diagnostics’, below). The probe concerned must be 
replaced.

Logger Diagnostics
Running the data logger diagnostics provides information on the status of the 
logger and the means to test the thermocouple probes. Short circuits and open 
circuits may be revealed: these are sometimes intermittent, and can be a 
function of temperature and/or rate of change of temperature, or caused by 
bending the probe cable.
1. Connect the logger to the PC (to minimize communications problems, 

connect the lead first to the PC and then to the logger). The red LED on 
the logger should flash five times to confirm that the connection between 
the communications lead and the logger has been made.

2. Connect a full set of thermocouple probes to the logger, leaving them at 
ambient temperature.

3. On the Insight software’s menu bar, select Logger > Comms Setup to open 
the Communications Setup dialog.

4. Click Test.
5. If the logger is detected, the Diagnostic section of the dialog appears (see 

p. 22). The Temperature list box identifies all available probe channels, the 
indicated temperature or status, and the temperature of the internal cold 
junction.

6. Check that all probes are indicating the same temperature. Replace any 
showing *OC* (open circuit), or having inconsistent readings indicating an 
intermittent short circuit.

7. Place the probes into a bowl of hot water and check that all probes show a 
similar increase in temperature. Replace any showing ambient temperature 
as this indicates a short circuit. If any probe shows a temperature 
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significantly less than ambient its plug may be incorrectly oriented in the 
logger socket or wired incorrectly.

8. Click OK to close the dialog.

Datapaq Service Department
If you cannot resolve your problem, please contact the Service Department at 
Datapaq (see title page for contact details).
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