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SAFETY  
WARNINGS

For safe use of Datapaq equipment, always:
•• Take care to follow its supplied instructions.
•• Observe any warning signs shown on the equipment.

Indicates potential hazard.
On Datapaq equipment this normally warns of high temperature, but, 
where you see the symbol, consult the manual for further explanation.

Warns of high temperatures.
Where this symbol appears on Datapaq equipment, its surface may be 
excessively hot (or excessively cold) and may thus cause skin burns.

© Fluke Process Instruments, Cambridge, UK  2018
All rights reserved

Fluke Process Instruments makes no representations or warranties of any kind whatsoever with respect 
to the contents hereof and specifically disclaims any implied warranties of merchantability or fitness for 
any particular purpose. Fluke Process Instruments shall not be liable for errors contained herein or for 

incidental or consequential damages in connection with the furnishing, performance or use of 
the Datapaq software, associated hardware or this material.

Fluke Process Instruments reserves the right to revise this publication from time to time and to make 
changes to the content hereof without obligation to notify any person of such revisions or changes.

Datapaq, Reflow Tracker and the Fluke Process Instruments logo are registered trademarks of 
Fluke Process Instruments. Microsoft and Windows are registered trademarks of Microsoft Corporation.

Manual set in 10 pt Gill Sans.
User manuals are available in other languages; contact Fluke Process Instruments for details.
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Introduction
Datapaq ® Reflow Tracker ®, incorporating Insight™ software, is a complete 
system for monitoring and analyzing the temperature profiles of products within 
all types of soldering processes. Power and flexibility make it a perfect tool for 
process temperature monitoring, from commissioning and troubleshooting to 
process optimization, ensuring consistent quality of product, consistent oven 
performance and maximum efficiency. Innovative analysis techniques help in 
identifying problems, fine-tuning the process and reducing running costs.

Insight is available for the reflow industry in different levels of sophistication to 
meet the requirements of all applications.

•• Reflow Tracker Professional – A high-end system, including the 
functionality of Surveyor (see below).

•• Reflow Tracker – The standard system for wide application, including 
ability to perform hardwired telemetry and (with additional hardware and 
software) radio telemetry, Easy Oven Setup, and analysis of oven trends 
using Statistical Process Control (see below).

•• Reflow Tracker Basic – A reduced feature set, but with full analysis 
options and wizard-driven procedures.

•• Reflow Lite – Essential features for profile-gathering and simple analysis.

Reflow Tracker is equally useful for other soldering applications such as wave solder, 
vapor phase, curing ovens and rework stations.

Telemetry options allow full monitoring of temperatures in real time while a 
job is actually in the oven: hardwired telemetry is part of the standard system 
(see the dedicated User Manual supplied with your data logger), and Reflow 
Tracker can be specified to include the TM21 radio-telemetry system.

Statistical Process Control (SPC) allows easy analysis of the results of 
profile runs over time, highlighting trends in the performance of your process, 
and allowing potential problems to be identified and dealt with before they 
occur.

Easy Oven Setup (not available in Insight Reflow Tracker Basic and Reflow Lite) 
enables users rapidly and accurately to set up their ovens for new products and/
or new solder formulations by predicting the recipes that should be used to 
achieve given temperature profiles – and with the Surveyor option (Insight 
Reflow Tracker Professional only) you can compare a reference profile (baseline 
survey) of your oven’s ideal performance against a profile which has been 
obtained subsequently – by a relatively unskilled operator – in order to check 
whether the oven performance has deteriorated.
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Powerful reporting facilities allow the user to generate customized printouts, 
including any or all of the analysis results or raw temperature data.

This manual contains the following sections:
•• Basic Hardware (p. 11) – The standard system’s thermal barriers and 
thermocouple probes, their specifications and their care and maintenance.

•• Reflow Temperature Profiles (p. 19) – All the stages of obtaining a 
temperature profile from a typical reflow process, including the positioning 
of probes and using the profiles to correct faults in the soldering process.

•• Wave Solder (p. 31) – Use of a Reflow Tracker system in a wave-solder 
process.

•• Easy Oven Setup (p. 37) – Set up an oven for a new product by 
predicting an oven recipe. (Not available in Insight Reflow Tracker Basic and 
Reflow Lite.)

•• Surveyor (p. 43) – Monitor an oven’s performance in order to assess 
trends and check whether it has deteriorated. (Insight Reflow Tracker 
Professional only.)

•• Troubleshooting (p. 51).

The dedicated User Manual supplied with your data logger should be read in 
conjunction with this manual. It provides information on operating the logger, 
including:

•• Installing Insight and establishing communication between logger and PC.
•• Resetting the logger with new data-collection parameters.
•• Downloading the collected data to the PC.
•• Use of hardwired telemetry.
•• Troubleshooting logger problems.

For full details on use of the Insight software, refer to the online Help system 
available when the software is installed.

System Components
A typical Reflow Tracker system comprises:

•• Data logger, with communications lead and charger; logger with radio-
telemetry option includes internal transmitter.

•• Receiver (radio-telemetry option only).
•• Thermal barrier – to protect the logger during its time in the oven.
•• Thermocouple probes.
•• Insight Reflow Tracker software.
•• User documentation:
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○○ Reflow Tracker User Manual.
○○ Data logger User Manual (specific to the logger model).
○○ TM21 Radio-telemetry System User Manual (radio-telemetry option only).

Additional hardware is supplied with Wave Solder (p. 31) and Surveyor 
systems (p. 43).

This manual, and other Datapaq user documentation, in various languages, is 
available on the Insight installation DVD included with Datapaq systems. During the 
software installation, you may select documents to be copied to your PC for rapid 

on-demand viewing through Insight.
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Basic Hardware
The standard Reflow Tracker system includes one or more thermal barriers and 
appropriate thermocouples.

For use of the data logger, and for other special-purpose hardware,  
see the documentation supplied with it.

Thermal Barriers
The thermal barrier provides the thermal and mechanical protection necessary 
for the data logger to survive in the hostile environment of reflow, wave-solder, 
vapor-phase and curing ovens.

A range of barriers is available to suit different loggers and different purposes. 
Specifications of barriers to fit the Datapaq DP5 logger are given below; these 
use Microtherm insulation for primary thermal protection.

WARNING 
It is essential to use the correct Datapaq thermal barrier for your individual process, 

as supplied and approved by Fluke Process Instruments. Failure to use the 
appropriate approved barrier, or the use of a barrier in an unapproved manner (e.g. 
using above the specified temperature, or for longer than the specified time, or with 

insufficient opportunity for adequate cooling between profile runs), can cause 
catastrophic damage to the data logger or to other equipment, can endanger 

health, or (if lithium batteries are being used) may lead to severe injury or death. 
For the same reasons, never use a damaged thermal barrier.

Ensure that all dimensions of your logger/barrier/accessory assembly are such that it 
will fit comfortably within the oven through all stages of the process. Pay particular 
attention to handles, catches, etc., and to trailing thermocouples. Failure to do this 

can cause the assembly to jam in the oven with consequent overheating and 
potentially-severe damage to the equipment. Resultant battery-leakage, and the act 

of recovering the equipment, may cause skin burns and respiratory irritation.
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Barriers for DP5 Logger Standard, 6-channel, DP5x60

These barriers also fit Q18 standard 6-channel logger, DQ1860.

TB2015 – Most reflow soldering processes including lead-free

Temp °C 100 150 200 250 280

Duration (mins) 32 16 13 10 9

Dimensions Height	 Width	 Length	 Weight 
25 mm	 133 mm	 210 mm	 0.7 kg 
1.0 in.	 5.2 in.	 8.3 in.	 1.5 lb 

TB2064 – Low-height thermal barrier

Temp °C 100 150 200 250 280

Duration (mins) 25 12 9 8 6

Dimensions Height	 Width	 Length	 Weight 
20 mm	 133 mm	 210 mm	 0.6 kg 
0.8 in.	 5.2 in.	 8.3 in.	 1.3 lb 

Part of the range of Datapaq thermal barriers for the Datapaq DP5 logger.
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TB2065 –	Increased protection for frequent use or for long-duration 
processes

Temp °C 100 150 200 250 280

Duration (mins) 35 18 13 11 10

Dimensions Height	 Width	 Length	 Weight 
29 mm	 133 mm	 210 mm	 0.7 kg 
1.1 in.	 5.2 in.	 8.3 in.	 1.5 lb

Barriers for DP5 Logger Super-slim, 6-channel, DP5x61

These barriers also fit Q18 super-slim 6-channel logger, DQ1861.

TB2066 – Low-height thermal barrier

Temp °C 100 150 200 250 280

Duration (mins) 21 11 8 6 6

Dimensions Height	 Width	 Length	 Weight 
20 mm	 88 mm	 334 mm	 0.65 kg 
0.8 in.	 3.5 in.	 13.1 in.	 1.4 lb

TB2067 – Most reflow soldering processes including lead-free

Temp °C 100 150 200 250 280

Duration (mins) 28 15 11 10 8

Dimensions Height	 Width	 Length	 Weight 
25 mm	 88 mm	 334 mm	 0.75 kg 
1.0 in.	 3.5 in.	 13.1 in.	 1.7 lb

TB2068 – Increased protection for frequent use or for long-duration 
processes

Temp °C 100 150 200 250 280

Duration (mins) 32 18 13 11 10

Dimensions Height	 Width	 Length	 Weight 
29 mm	 88 mm	 334 mm	 0.8 kg 
1.1 in.	 3.5 in.	 13.1 in.	 1.8 lb
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Barriers for DP5 Logger Narrow, 6-channel, DP5x62

These barriers also fit Q18 narrow 6-channel logger, DQ1862.

TB2020 – Low-height thermal barrier

Temp °C 100 150 200 250 280

Duration (mins) 25 13 10 8 7

Dimensions Height	 Width	 Length	 Weight 
28 mm	 84 mm	 241 mm	 0.5 kg 
1.1 in.	 3.3 in.	 9.5 in.	 1.1 lb

TB2021 – Most reflow soldering processes including lead-free

Temp °C 100 150 200 250 280

Duration (mins) 36 18 13 11 10

Dimensions Height	 Width	 Length	 Weight 
35 mm	 84 mm	 241 mm	 0.65 kg 
1.4 in.	 3.3 in.	 9.5 in.	 1.4 lb

Barriers for DP5 Logger, 12-channel, DP5x12

TB2100 – Low-height thermal barrier

Temp °C 100 150 200 250 280

Duration (mins) 25 13 10 8 7

Dimensions Height	 Width	 Length	 Weight 
28 mm	 133 mm	 243 mm	 0.69 kg 
1.1 in.	 5.2 in.	 9.6 in.	 1.5 lb

TB2101 – Most reflow soldering processes including lead-free

Temp °C 100 150 200 250 280

Duration (mins) 36 18 13 11 10

Dimensions Height	 Width	 Length	 Weight 
35 mm	 133 mm	 239 mm	 0.77 kg 
1.4 in.	 5.2 in.	 9.4 in.	 1.7 lb
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Barriers for Q18 Micro Logger, DQ1804

TB2098 – Reflow soldering processes
Duration 10 mins at 200°C.

Dimensions Height	 Width	 Length	 Weight 
27 mm	 57 mm	 190 mm	 0.4 kg 
1.1 in.	 2.2 in.	 7.5 in.	 0.9 lb

TB3006 – Long-duration reflow soldering processes
Duration 14 mins at 200°C.

Dimensions Height	 Width	 Length	 Weight 
32 mm	 71 mm	 194 mm	 0.6 kg 
1.3 in.	 2.8 in.	 7.6 in.	 1.3 lb

Thermocouple Probes
Thermocouple probes utilize an effect by which an e.m.f. is produced in any 
electrically conducting material that is not at uniform temperature. The actual 
voltage measured is proportional to the temperature difference between the 
thermocouple’s ‘hot’ and ‘cold’ junctions (the hot junction being the 
measurement junction, and the cold junction being the junction of thermocouple 
and measurement instrumentation).

The practical implementation of thermocouples requires sophisticated 
electronics to eliminate potential measurement errors which include poor 
linearity over the measurement range, and inaccuracy due to temperature 
variations at the cold junction. To accommodate these the electronics in the 
measuring system must simulate a temperature of 0°C at the cold junction, as 
well as compensating for any non-linearity over the range of thermocouple 
operation.

Over the years, ‘standard’ thermocouples have been developed using materials 
chosen for sensitivity, linearity (consistency of sensitivity over the useful 
temperature range), price and availability. Current standards include types K, N, 
R, S and T, each type being identified by its connector color. The standard 
thermocouple probe for reflow industry use is type K.

All Reflow Tracker systems are supplied with one set of PTFE-insulated 
thermocouple probes (part no. PA0210). Other probes available are:

•• High-temperature glass-fiber-insulated (PA0215).
•• Fine-wire, for use on ball grid arrays (BGAs) (PA1683).
•• Special probes for wave-solder pallet (p. 31).
•• Surveyor sensors. See p. 46.
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All have green type-K connectors (conforming to IEC 60584-3).

WARNING 
Never connect thermocouples to mains electricity, nor allow thermocouples to 

touch an oven’s heating elements. This could cause major injury or death.
Take care when handling thermocouple cables to avoid accidental damage to the 

eyes by sharp thermocouple-tips.

Thermocouple Specification

Probe 
Type

Temperature 
Range

Cable Insulation Accuracy of Probes Supplied 
by Datapaq (ANSI MC96.1)

K −150°C to 1,370°C Glass fiber or PTFE ±1.1°C or ±0.4% at 0–1,250°C

The presence of a probe on the product adds to the product’s thermal mass, 
changing – however slightly – its rate of heating and cooling. To minimize the 
probe’s thermal mass, and therefore its affect on the product, the type K 
probes supplied with the Reflow Tracker system are constructed from 0.2-mm 
wire.

Thermocouple Cables

The practical operating temperature of the thermocouple probes is limited by 
the cable insulation material’s temperature characteristics.

Probes insulated with thin glass fiber, impregnated with a silicone resin binder, 
are suitable for use at temperatures up to 500°C continuously and 700°C short 
term and should be used if the probe cables could come into close 
proximity with infra-red heating elements.

PTFE (polytetrafluoroethylene)-insulated probes are suitable for general-
purpose use at temperatures up to 260°C. PTFE is a robust, flexible, non-stick 
material, with a low thermal mass and therefore a quick response time. This is 
the standard insulation for reflow use, though it cannot be used when probe 
cables may be close to infra-red heating elements.

WARNING 
PTFE does not support combustion, but decomposes above 265°C producing small 

amounts of toxic fumes.
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The important products from PTFE thermal decomposition are:

At Temperatures Greater Than: Product

400°C See note*

430°C Tetrafluoroethylene

440°C Hexafluoropropylene

475°C Perfluoroisobutylene

500°C Carbonyl fluoride*, which, in moist air, 
converts to the acid gas hydrogen fluoride 

*	 May also be produced if PTFE tape is kept at 400°C for an extended time.

Health Hazard Data

•• Inhalation of decomposition products from PTFE can produce ‘polymer fume 
fever’, which has symptoms similar to influenza.

•• There is no risk from ingestion or skin contact.
•• There are no medical conditions generally aggravated by exposure to PTFE.

Emergency and First-aid Procedures

•• If there is accidental contact with PTFE fumes, remove the person 
concerned to clean air.

•• Self-contained breathing apparatus and protective clothing should be worn 
when fire-fighting.
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Reflow Temperature 
Profiles: Creation and Use
A temperature profile can be acquired by two means:

•• Without telemetry – After the logger and product have been in the oven, 
data is downloaded from the logger into the PC to be displayed and analyzed 
by the Datapaq Insight software.

•• Using telemetry – As the logger gathers data from the product inside the 
oven, this is transmitted directly to the PC by a hard-wired connection 
(serial telemetry) or by radio transmitter/receiver (radio telemetry). The 
temperature profile can be watched developing as it happens, i.e. in real 
time. For the use of hardwired telemetry, see your dedicated logger User 
Manual. For radio telemetry, see the TM21 Radio-telemetry System User 
Manual.

This chapter describes all the stages of obtaining a reflow temperature profile 
for a PCB while it is in the oven, without telemetry – from how and where to 
place the probes, to downloading the data into the software, ready to be 
analyzed.

To run a temperature profile in a wave-solder oven, see p. 31.

Before running your PCB and the data logger through the oven you will use the 
Insight software to reset the logger, i.e. to prepare it for receiving fresh data. 
After the logger has been retrieved from the oven, you will use Insight again to 
download the profile data and save it to disk. 

In summary, the stages are as follows.
1.	 Choose positions for, and attach, the thermocouple probes.
2.	 ‌Setup communication between the data logger and your PC (if this has 

not already been done for a previous profile run).
3.	 ‌Reset the data logger so that it is ready to receive fresh data; in the 

process of doing this you will also be able to set the sample collection 
interval and the method used to trigger the start of data collection, and to 
check the logger’s battery status.

4.	 Install the logger in its thermal barrier.
5.	 Run the PCB and logger/barrier through the oven.
6.	 ‌Download the data from the logger into the Insight software.
7.	 If necessary, set the oven start position within the data.



20	 Reflow Temperature Profiles	 REFLOW TRACKER

8.	 Add any additional information that you wish to have recorded with the 
profile data.

After this, Insight can be used to analyze the profile data as required.

Probe Location
Whatever the method of heating, the thermal mass of the PCB, its tracks and 
the components attached to them significantly influence the time taken for each 
physical element to attain a given temperature. Positioning of probes is thus 
crucial in ensuring that all key parts of the PCB follow a specified temperature 
profile, usually based on data from the solder-paste manufacturer.

Main Considerations

•• Large ground planes absorb 
more heat and take longer to 
achieve reflow temperatures 
than narrow tracks.

•• Large quad flat packs and ball-
grid arrays absorb a lot of heat; 
they are also more susceptible 
to damage by thermal shock 
than most other components.

•• Large surface-mount devices 
can shade the tracks to which 
they are to be soldered.

•• The edges of the PCB heat 
more rapidly than the center.

•• Is the track density even? If so, the heating may be more uniform; if not, 
there may be localized hot and cold spots.

•• Is the board double-sided? If so, it may have to go through the oven twice: 
the bottom of the board must be kept below reflow temperatures or solder
ability could be lost, de-wetting experienced, and components could fall off.

•• Is it a multi-layer board? If so, it is likely to have more copper and so require 
more heat, but it may heat more evenly.

Typical Probe Locations

•• Locations likely to achieve the fastest rate of temperature increase, e.g. 
board edges and/or locations of components with low thermal mass.

•• Locations having a high thermal mass which may require extra time to 
achieve reflow temperature. 

Probes attached to the PCB and components.
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•• Locations shaded by large components, i.e. tracks under large quad flat packs 
and ball-grid arrays which may require extra time to achieve reflow 
temperature. Note that it may be necessary for thermocouple cables to exit 
via a hole to the underside of the PCB.

•• The underside of double-sided boards.
•• Ideally, to ensure profiling is reliable and repeatable, test samples of each 
type of PCB with thermocouples permanently attached should be kept 
specifically for this purpose.

Due to drying and slight changes in color, the test sample PCB’s thermal 
characteristics have a tendency to change slightly each time it passes through the 

oven. Any obviously discolored boards should be discarded and replaced.

Probe Attachment
Good thermal contact between probe and product is essential if the probe is to 
reflect accurately the product’s temperature. Poor thermal contact will at best 
result in slowing the rate at which the product heats the probe, and at worst 
prevent the probe achieving the temperature of the element on which it is 
mounted.

Good Practice

•• Ensure probe tips are clean before attaching them to PCB or component.
•• Secure probes along their length to ensure they remain in position, cannot 
foul elements in the oven, do not thermally shade the product, and will not 
experience excessive temperatures by being too close to heater elements.

•• Use glass-fiber insulation when thermocouple cables will be in close proximity 
to infrared heating elements or experience temperatures in excess of 260°C.

For further guidance on good practice in thermal profiling – especially 
in probe attachment – see the following documents.

•• Moisture/Reflow Sensitivity Classification for Nonhermetic Surface Mount 
Devices. IPC/JEDEC standard J-STD-020E. 
http://www.ipc.org/TOC/IPC-JEDEC-J-STD-020E.pdf

•• Guidelines for Temperature Profiling for Mass Soldering (Reflow & Wave) 
Processes. IPC-7530A. 
http://shop.ipc.org/IPC-7530A-English-D 
http://www.ipc.org/TOC/IPC-7530.pdf

•• Thermal profiling of electronic assemblies. NPL report MATC(A)50. 
http://publications.npl.co.uk/npl_web/pdf/matc50.pdf
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Methods of Attachment

The following are the chief methods.

High-melting-point Solder

•• Gives best repeatability but difficult to perform.
•• Recommended for metal-to-metal attachment.

High-melting-point solder is used to attach thermocouples to the legs of 
components and to PCB tracks. It melts far enough above reflow temperature 
to ensure that the thermocouple remains in place.

To be successful, any low-melting-point solder must be removed, allowing high-
melting-point solder to be applied directly to the metal to be joined. Use as 
little solder as possible, as follows.
1.	 Remove any low-melting-point solder. Clean the thermocouple then tin it 

using high-melting-point solder. Clean the component leg or PCB track to 
which the thermocouple will be attached. Tin it using high-melting-point 
solder.

2.	 Solder the thermocouple in place, using as little high-melting-point solder as 
is consistent with a satisfactory joint. Ensure the cable lies flat along 
the PCB.

SMA Adhesive

•• Gives good results.
•• Much easier to carry out than soldering, but adhesive needs to be cured.

The best results are obtained as follows.
1.	 Pre-form the thermocouple cable and hold it in place on the PCB with high-

temperature tape, ensuring that the thermocouple tip is in good contact 
with the joint to be measured.

2.	 Place a small bead of SMA adhesive on the thermocouple tip.
3.	 Follow the manufacturer’s specification to ensure correct curing of the 

adhesive: most SMA adhesives are heat-cured and this can be achieved by 
running the PCB once through the oven before the first data-collection run.

High-temperature Adhesive Tape

•• A temporary means of holding cables in position on the PCB. For one-off 
trials only.

•• If used in conjunction with aluminum tape, forms a reasonable method of 
attachment if high-melting-point solder or SMA adhesive cannot be used.

High-temperature (Kapton) tape is recommended as a means of restraining 
thermocouple cables where they run over the PCB (see below) but not of fixing 
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them to the measuring point. However, attachment is improved by using self-
adhesive aluminum tape and deforming it to fit closely around the thermocouple 
tip; high-temperature tape placed over this will hold it in place during the 
profile run.

Restraining the Cable

The thermocouple cables must be routed from their points of attachment to 
the rear of the PCB to enable the data logger to follow the PCB through 
the oven. 
1.	 Route the thermocouples from their points of attachment to the rear of 

the PCB.
2.	 Attach the thermocouple cables to the PCB at intervals, using high-

temperature tape.

Preparing the Logger
•• If the data logger is being connected to a PC for the first time, it is 
necessary to enable communication between them. 

•• The logger must also be reset before a profile run – using Insight software – 
to establish its data-collection parameters (not necessary if parameters are 
to be unchanged from the previous run). 

•• If there is any doubt that the logger’s battery charge may be inadequate 
for the profile run, this must also be checked by using the reset procedure.

For the procedures involved, see your dedicated logger manual or 
the Insight Help system.

Note that, since its last use, the logger must have cooled below 35°C 
(comfortable to hold without gloves).
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Installing the Logger in the Thermal Barrier

WARNING 
It is essential to use the correct Datapaq thermal barrier for your individual process; 

see p. 11. Ensure that all dimensions of your logger/barrier/accessory assembly 
are such that it will fit comfortably within the oven through all stages of the process. 

Pay particular attention to handles, catches, etc., and to trailing thermocouples. 
Failure to do this can cause the assembly to jam in the oven with consequent 

overheating and potentially-severe damage to the equipment. Resultant battery-
leakage, and the act of recovering the equipment, may cause skin burns and 

respiratory irritation.
Ensure the thermal barrier has cooled sufficiently since its last use.

1.	 Plug the thermocouples into the logger’s numbered sockets. If you are 
using a process file, ensure that the probe/socket numbers on the logger 
correspond to those used to define probe numbers and locations in that file 
(see the Insight software for an introduction to process files: press function 
key F1, or select Help > Contents from the menu bar, and click the section 
‘Process Files: Oven, Recipe, Product’).

2.	 If the trigger mode is start button, press and hold the logger’s start button 
for about 0.5 second until the green LED starts to flash at the sample 
interval.

Data-recording cannot start until the 
logger has cooled sufficiently from 
the previous run. If it is still too hot, 
pressing the start button will cause 

the logger-status red LED to give two 
quick flashes every second.

If the battery has less than 20% of 
full charge, data-recording cannot 
start until the battery is charged.

3.	 Ensure the barrier’s sealing 
surfaces are clean and 
undamaged. A good seal between 
barrier and thermocouple cables is essential if the logger is to be protected. 
Put the logger in place in the barrier, laying the thermocouple cables 
across the sealing material to exit the barrier at the cutout, ensuring they 
are side by side and not crossing each other.

4.	 ‌Fit the lid, ensuring a good seal around the thermocouple cables. Secure 
the lid’s catches with the locking pins, if fitted.

The logger in place in its 
thermal barrier.
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WARNING 
Take care not to trap fingers when closing the barrier lid.

Placing the System in the Oven
1.	 Place the instrumented PCB on the oven’s conveyor with the thermocouple 

cables towards the rear.
2.	 As the board travels 

towards the oven feed 
the thermocouple cables 
carefully, ensuring they 
do not foul the oven.

WARNING 
Never allow 

thermocouples to touch 
an oven’s heating 

elements. This could 
cause major injury 

or death.

3.	 Load the logger and 
thermal barrier onto the 
conveyor some distance 
behind the PCB to 
ensure their thermal mass does not affect the PCB’s heating and cooling. If 
the oven has an edge conveyor, place the thermal barrier on a carrier plate.

Removing from the Oven and 
Downloading Data
Recover the system from the oven as soon as the run is over.

WARNING 
The thermal barrier and logger will be hot enough to burn skin – even though 

their temperature will not be apparent. Use protective gloves. 
Failure to remove the logger quickly from the hot thermal barrier could 

damage the logger. 
Do not remove the logger by tipping it out of the barrier. This can lead to injury by 

dropping the logger onto your body, and may damage the logger.

An instrumented PCB on its way into the oven (to 
the right), with the thermal barrier and logger 

following behind.
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1.	 Open the thermal barrier. Placing it on a cold surface will increase its rate of 
cooling. (An additional thermal barrier should be purchased if insufficient 
time is available to allow it to cool between test runs.)

2.	 If data acquisition has to be stopped manually, press and hold the logger’s 
red stop button until the red and green logger-status LEDs both flash once. 
A red logger-status LED flashing every 5 seconds indicates data stored in the 
logger but not yet downloaded to the PC.

3.	 ‌Download the data from the logger to the PC using the Insight software. 
For the procedures involved, see your dedicated logger User Manual or the 
Insight Help system (under Contents, select Menu > Logger > Download).

Analysis of Reflow Temperature Profiles
For details of the many analyses that can be performed on your profiles, see 
Insight’s Help system (under Contents, select Data Analysis).

These notes are not a comprehensive guide to the importance of temperature 
profiles in the reflow soldering process, but are intended to highlight possible 
faults associated with a poor profile shape. See p. 21 for other sources of 
guidance on the use of temperature profiles.

Profile Types

The two common profile shapes used in reflow soldering are the Ramp Soak 
Spike (RSS) and the Ramp To Spike (RTS, or tent profile). The RSS was 
developed when oven performance was such that a long dwell time was 
required to enable components of differing thermal mass to achieve the same 
temperature before the spike up to reflow temperature. With improvements in 
oven performance it has been possible to use a constant ramp up in 
temperature to the reflow temperature; this RTS profile is generally much 
easier to set up on the oven and avoids the double thermal shock to which 
small components can be subjected when using the RSS profile.

However, the use of lead-free solders requires higher soldering temperatures, 
and this – combined with the very wide range in thermal mass of modern SMT 
components – means that the RSS profile is still often the best solution. If this is 
the case, the temperature profile needs to be set up carefully in order to ensure 
compliance with both solder-paste specifications and with soldering-related 
aspects of component specifications.
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Checking Profiles

Some soldering faults which can be caused by incorrect temperature profiles are 
described below.

•• Incomplete soldering – There are numerous possible causes, one of 
which is insufficient heat energy input to the solder joint. This would usually 
be caused by too low a temperature before the reflow zone or too short a 
time above the liquidus temperature of the solder.

•• Tombstoning (drawbridging or Manhattan effect) – A leadless 
component is lifted at one end during soldering, due to uneven wetting of 
the two terminations. This can be caused by many factors including PCB pad 
design and component layout. To help ensure that the two ends of the com
ponent are soldered at the same time, the profile shape should be adjusted 
to minimize the rate of heating as the liquidus temperature is reached.

•• Misalignment of soldered components – This is a less severe 
manifestation of the problems that cause tombstoning, and thus the same 
remedies can be applied. Careful profiling, placing many thermocouples in 
the area affected, may reveal large temperature gradients in that area of the 
assembly. These may be alleviated by passing the PCB assembly through the 
process in a different orientation.

•• Component cracking/mechanical failure – The cracking or fracture 
failure of small ceramic components can be caused if the change in 
temperature (heating or cooling) is too rapid. Use Insight software’s Slopes 
analysis mode to find the maximum slope (temperature gradient, °C/s) and 
compare this to the limits set by the component manufacturer; these limits 
may well be different from any limits specified by the solder-paste supplier.

•• Solder balling/beading – Often caused by excessive deposits of solder 
paste and then outgassing as the product is heated. It can be improved by 
reducing the rate of temperature rise in the ramp zone.

•• Poor wetting of solder joints – If the cause is thought to be within the 
thermal processing of the assemblies, there may be oxidation of the leads 
and/or pads before the solder reaches liquidus. Possible remedies include 
reducing the dwell time in the middle part of the temperature profile or 
reducing the temperatures in this area.

•• Voiding – Voids are generally caused by air trapped in ‘via holes’ in the 
component pad or by outgassing of the solvents within the solder paste. 
Changes to the temperature profile may improve this: either shortening the 
soldering time or slowing the ramp rate.

Statistical Process Control

SPC is a powerful feature of the Insight software which allows easy analysis of 
the results of your profile runs over time. Thus, by highlighting trends in the 
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performance of your process, potential problems can be identified and dealt 
with before they occur. (Not available with all versions of Insight.)

The Datapaq Surveyor system (p. 43) is an alternative means of assessing oven 
performance which requires you to use specific hardware first to quantify and then 
to run checks on the system to ensure it is still operating within limits. Using SPC on 
normal Insight paqfiles, on the other hand, requires only the analysis of your routine 
profile runs to assess trends in the oven’s performance. Both systems have benefits 

and limitations, as shown below.

Pro Con

SPC on 
normal 
paqfiles 

•• Measures temperatures of the 
actual PCB assembly during the 
process. 

•• Comprehensive report shows data 
from each probe separately.

•• Can monitor wave, vapor-phase 
and rework soldering processes, as 
well as reflow. 

•• Good thermocouple sensor connection 
is essential for best results. 

•• If used on data obtained with standard 
test PCBs (‘golden boards’) and their 
associated thermocouples, these will 
degrade with repeated use, producing 
less reliable results.

•• Placing logger/PCB assembly on the 
conveyor requires care to ensure that 
thermocouple wires will not be trapped 
in the oven.

•• Need to ensure details of data-collection 
are standardized for all profiles. 

Surveyor •• Unskilled operator can conduct 
routine profile runs to assess 
oven’s performance.

•• Only one item to place on the 
oven conveyor.

•• Logger is reset, and results are 
saved, automatically.

•• Immediate confirmation of whether 
the oven is operating within 
specification for a given process.

•• Helps to ensure details of data-
collection are standardized.

•• Measures only the performance of the 
process, not the temperatures 
experienced by the actual product.

•• For reflow processes only. 

Using SPC

Note that, for SPC results to be meaningful, the paqfiles analyzed must be 
consistent, i.e. they must relate to the same process (the same oven with the same 
recipe settings) and must have used the same test-piece with probes in the same 

positions. It is important that the test-piece is maintained in good condition.
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An SPC analysis is easily carried out using SPC Setup Wizard (click  or  on 
the Insight toolbar, or select Tools > Wizards from the menu). This guides you 
through the following stages:
1.	 Select existing temperature profiles (paqfiles) on which the analysis will be 

based.
2.	 Choose which analysis results you will examine, and set a target value and 

acceptable limits for the results.
3.	 Insight then calculates the SPC results and displays them as a new graph in 

the Graph Window, and as tabulated data in the Analysis Window.

For each probe, the value of each paqfile’s chosen analysis parameter (on the 
y-axis) is plotted against the data collection time of the paqfile (on the x-axis). 
Any trend in the results over time can thus be identified and compared with 
your specified target value and acceptable limits, which are shown on the graph 
as horizontal lines.

Functions that can be performed on an SPC analysis include:
•• Modify it by changing:

○○ the files used for the analysis;
○○ the analysis results examined;
○○ the target value and acceptable limits for the results.

•• Save the results for future display and analysis.
•• Print a detailed report of the results: from the main menu, select File > 
Print Options.

•• Export the results for use in another software application.
•• Email the full results.

Full guidance on using SPC is provided in Insight’s online Help:  
press function key F1, or select Help > Contents from the menu bar, and then in 

the Help system select Data Analysis > Statistical Process Control.

For further features of the Insight software – particularly the use of process 
files – see the Help system.
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Wave Solder
The Datapaq Reflow Tracker system – and Insight software – can be used with 
both reflow and wave-solder ovens.

In the Wave Solder system, the logger (in its thermal barrier) is mounted on a 
flat pallet (part no. CS5000) which passes through the oven. Up to nine fixed 
thermocouples on the pallet measure conditions relating to the solder wave: the 
oven’s line-speed and the contact length of the solder wave, and thus the 
contact time with the solder. Up to eight of the fixed thermocouples lie in front 
of the logger on the pallet’s leading edge (i.e. entering the oven first) and one is 
towards the rear of the pallet. The vertical position of the fixed thermocouples 
can be adjusted in order to alter the depth of their penetration into the solder 
wave.  The rear part of the pallet holds a dummy PCB (a ‘test coupon’) 
instrumented with three additional thermocouples which gather data on 
conditions in the oven’s preheat zone.

1

2

3

4

11

12

Datapaq wave-solder pallet CS5000 with fixed dummy PCB at right and thermal 
barrier in place. All 12 thermocouples are connected to the logger inside the barrier, 

and the thermocouples’ identifying numbers (see text) are shown. The pallet travels to 
the left, into the oven.
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Reflow Tracker’s Insight software identifies the thermocouples as follows:
•• Thermocouples attached to the PCB are numbered 1–3.
•• With a 6-channel logger, the leading-edge thermocouples are numbered 4–5 and 
the rear thermocouple is number 6.

•• With a 12-channel logger, the leading-edge thermocouples are numbered 4–11 
and the rear thermocouple is number 12.

The Reflow Tracker system can also be used to profile the process without a pallet 
by attaching thermocouples solely to a product or test-piece, as in reflow profiling.

Running a Wave-solder Temperature Profile
The process of running a wave-solder temperature profile is carried out using 
Insight’s Wave Solder Wizard. A profile can be obtained in two ways:

•• Wave with Pallet – Thermocouples are fixed to a flat pallet, on which the 
logger is also mounted, and this passes through the oven.

•• Wave – Using a standard assembly of logger and thermal barrier (and no 
pallet), thermocouples are attached to a separate product or test-piece 
which passes through the oven, as in reflow profiling.

For a Wave profile run (i.e. without pallet), note that Wave Solder analysis is 
performed only on data from thermocouples on the underside of the PCB, i.e. 
those which make contact with the solder wave. These thermocouples must be 
specified.

Profiling method and (for a Wave profile) the thermocouple numbers used will 
be most conveniently specified by use of a process file which you apply to the 
profile data after the run has been performed (see below).

See the Insight software for an introduction to process files: press function key F1, 
or select Help > Contents from the menu bar, and click the section  

‘Process Files: Oven, Recipe, Product’.

Profiling method is specified by selecting the oven type in the process file or, 
alternatively, in the Process Details dialog (Oven tab).

As well as in the process file, the thermocouples used can be specified in the 
Process Details dialog (Recipe–Analysis tab) or in the Analysis Options dialog of 
the Wave Solder analysis.
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Preparing the System for the Oven

WARNING 
It is essential to use the correct Datapaq thermal barrier for your individual process; 

see p. 11. Ensure that all dimensions of your logger/barrier/pallet assembly are 
such that it will fit comfortably within the oven through all stages of the process. 

Failure to do this can cause the assembly to jam in the oven with consequent 
overheating and potentially-severe damage to the equipment. Resultant battery-

leakage, and the act of recovering the equipment, may cause skin burns and 
respiratory irritation.

1.	 Connect the communications lead to the data logger and start the Wave 
Solder Wizard in the Insight software (click  or  on the Insight 
toolbar, or select Tools > Wizards from the menu). The wizard takes you 
through the necessary steps, one after the other, to reset the logger ready 
to perform a wave-solder run.

2.	 When instructed by the wizard, plug the thermocouples into the logger’s 
numbered sockets, as follows.

It is essential to follow carefully the wizard’s instructions about probe 
positioning – or the analysis of data will be invalid.

For a Wave with Pallet profile run, follow the connection diagram shown 
in the Wave Solder Wizard (‘Position Probes’ stage), as follows:

•• Channels 1–3 on the logger must be connected to the dummy PCB.
•• Channel 4 on the logger must be connected to the right-hand leading-
edge thermocouple on the pallet (as viewed from above, with direction 
of travel pointing away from you).

•• Connect channel 5 (for a 6-channel logger) or channel 11 (for a 
12-channel logger) to the left-hand leading-edge thermocouple.

•• The channel connected to the pallet’s rear thermocouple must be 
number 6 for a 6-channel logger or number 12 for a 12-channel logger.

If using a non-Datapaq pallet, you must specify in the wizard the distance 
by which the rear thermocouple is behind the leading-edge thermocouples.

For a Wave profile run:
•• Attach thermocouples to the product or test-piece as required. The 
thermocouples used to monitor the wave (whose data is to be used 
subsequently in the Wave Solder analysis) must be fixed in such a way 
that they contact the main wave, i.e. on the solder side of the PCB; these 
thermocouple numbers must have been specified in Insight (see above). 
Other thermocouples can be connected to either side of the PCB as 
required.
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3.	 After the thermocouples are attached, ensure the mating surfaces of the 
thermal barrier – mounted securely on the pallet, if used – are clean and 
undamaged. A good seal between the barrier and the thermocouple cables is 
essential if the logger is to be protected. Put the logger in place in the 
barrier, laying the thermocouple cables across the sealing material to exit the 
barrier at the cutout.

4.	 Press and hold the logger’s start button for about 1 s until the green LED 
starts to flash. Insight automatically sets the sample interval at 0.05 s for all 
wave-solder profiles to ensure accurate line-speed and contact-time 
measurements.

5.	 Close the barrier lid, ensuring a good seal around the thermocouple cables.
6.	 Place the pallet/logger/barrier/PCB assembly (depending on configuration) 

on the oven’s conveyor. With a pallet, ensure correct direction of travel, as 
marked on the pallet.

WARNING 
Never carry the pallet assembly by holding the attached thermocouples. This can 
lead to injury by dropping the equipment onto your body, and may damage the 

equipment itself.

Removing from the Oven and Downloading Data

Recover the system from the oven as soon as the run is over. Open the thermal 
barrier and remove the logger.

WARNING 
The assembly, including logger, can be hot enough to burn skin – even 

though its temperature will not be apparent. Use protective gloves.
Failure to remove the logger quickly from the hot thermal barrier could 

damage the logger.

Continue following the Wave 
Solder Wizard to download 
the data to the PC and, if 
required, choose a process 
file to be applied to the 
results. The temperature 
profile is then displayed on 
screen, with a Wave Solder 
analysis of the data shown 
beneath it.
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Analysis of Wave-solder Temperature 
Profiles
For details of analyses that can be performed on a wave-solder profile, see 
Insight’s Help system (under Contents, select Data Analysis > Wave Solder).

Note that the temperature profiles resulting from reflow and wave-solder ovens 
require different analyses, and consequently the data files (paqfiles) which Insight 
produces for each also differ and are not interchangeable – nor can a process file 
for one type of oven be applied to a paqfile from the other type; see Insight’s Help 

system (under Contents, select ‘Reflow or Wave Solder?’).

Checking Profiles

The wave solder process (p. 31) is well understood and generally has a wider 
tolerance than reflow soldering. Some of the more common process faults that 
can be caused by the thermal profile are listed below. More comprehensive 
information is generally available on the websites of the larger wave-solder-
machine suppliers such as Vitronics Soltec or Electrovert.

•• Insufficient solder flow – Occurs when the solder has not had sufficient 
time to penetrate the holes around the component leads. There are 
numerous possible causes, but those that are related to the profile could be 
insufficient flux activation due to poor pre-heat temperatures or insufficient 
contact time with the wave. In each case, the profile should be used to verify 
the temperatures/times against those which are recommended. For the pre-
heat zone, temperatures should be checked on the actual product in the 
area where the problem is seen, as component size and placement can affect 
the temperature reached.

•• Solder balling/beading – There are many possible causes, but one related 
to the thermal profile is insufficient flux activation. In this case, the pre-heat 
temperature needs to be raised to increase paste activation in line with the 
manufacturer’s recommendations.

•• Component cracking – The most likely cause is too rapid a temperature 
change while moving from the pre-heat zone to the wave. After the wave, 
cooling is generally not forced, so the temperature gradient here is less 
severe.

•• Re-melting of top-side SMD joints – If the solder on the top-side 
components is re-melted during subsequent wave soldering, the quality of 
the SMD solder joints will be compromised. The remedy is to reduce total 
heat input to the PCB during soldering, which may involve reducing the 
solder temperature and adjusting the pre-heat temperature.
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Easy Oven Setup
Not available in Insight Reflow Tracker Basic and Reflow Lite.

Easy Oven Setup provides a rapid, simple and effective way to tune the settings 
of your reflow oven in order to produce the temperature profile you require 
for a specific solder paste and a specific application. It lets you achieve this in 
two different ways:

•• Profile Prediction  Alter the oven settings of an existing temperature 
profile to predict a new desired profile.

•• Recipe Prediction  Use the specification of your solder paste to 
create recipes predicted to produce the desired temperature profile.

For full details of Easy Oven Setup and all other aspects of the Insight software – 
particularly data analysis and the use of process files – see the online Help 

system (on Insight’s menu bar, select Help > Contents).

Profile Prediction
By starting with an existing temperature profile, you may alter the oven settings 
which were used originally to produce it, and immediately see the predicted 
effect of those adjustments on the profile shape. By a succession of such 
predictions it is thus possible to arrive at a recipe which will produce a desired 
target profile. The stages are as follows.
1.	 Open the temperature profile (paqfile) to be used as the basis for 

prediction. Ensure that the paqfile has a process file (see above) associated 
with it, and that the oven start position is set correctly.

2.	 Click  or select Easy Oven Setup > Profile Predict.
3.	 The prediction is then performed, and the results are displayed in the main 

Graph and Analysis Windows.

4.	 In the Oven Settings grid, oven zone temperatures can be edited: enter new 
trial values in the ‘New’ column, and click  to predict and display a revised 
profile (if lower and upper oven zone temperatures have been set differently 
in the recipe of the original profile, both are shown); repeat this to modify 
the shape of the profile as necessary. Predicted results are listed first in the 
analysis grid, and in the graph window the predicted probe traces are 
overlaid (in brighter colors) on the original profile. To change the sort order 
of the probes in the analysis grid, click  or .
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5.	 To save the revised recipe, click  to the left of the Oven Settings grid.
6.	 To save the predicted profile, click  on the main toolbar, or select File > 

Save, or File > Save As > Prediction; the profile is saved as a prediction file 
with a .PRE extension.

In order to ensure successful predictions, unheated oven zones must 
be specified.

After a profile prediction has been performed, some parts of the process file that 
were applied to the original paqfile will affect the prediction and will therefore not 
be editable, e.g. adding a zone to an oven would invalidate the prediction and thus 

is not possible.

You may overlay another paqfile and a tolerance curve on a prediction, e.g. to 
compare the prediction with an actual profile run.

Prediction files produced by using the Rapid Oven Setup module in earlier versions 
of Insight – which also carry a .PRE extension – are not compatible with 

this software.

Recipe Prediction
By using data from your solder-paste specification, Insight will create recipes 
which are predicted to produce temperature profiles to match the solder’s 
preferred usage conditions.
1.	 Setup process limits by assembling data from your solder-paste 

specification so that it can form the basis for a prediction: select Easy Oven 
Setup > Process Limits (see below).

2.	 Carry out the prediction: click  or select Easy Oven Setup > Recipe 
Predict (see p. 40).

3.	 Use the graphical and numerical display of the predicted temperature 
profiles and their analyses in order to choose from, and to adapt, the 
predictions created.

In order to ensure successful predictions, unheated oven zones must 
be specified.

Setting Process Limits

Selecting Easy Oven Setup > Process Limits runs the Process Limits Wizard in 
which you assemble data from your solder-paste specification so that it can 
form the basis for a recipe prediction.
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Supplying data for four aspects of the desired profile shape is optional: Overall 
Profile Slopes, Ramp, Soak and Spike. For each of these, check the box to 
enable the setting of their parameters (this is disabled by default).

•• Overall Profile Slopes  Specify the maximum permitted heating slope 
(rate of temperature increase) for the profile (default 4.0°C/s) and the 
maximum permitted cooling slope (default −4.0°C/s; a negative value must 
be entered). If you wish, enter a single target value for the heating slope 
(default 2.0°C/s).

•• Ramp  Define the temperature range (default 25–150°C) for the ramp 
phase (the initial rise) of the desired profile, and its target slope (default 
2.0°C/s).

•• Soak  If the desired profile is to have a soak (plateau) phase, define the 
temperature range (default 150–200°C) for the soak phase, and its 
permitted range of duration (time) (default 1–3 mins).

When ‘Soak’ is checked, the process limits will create a ramp/soak/spike 
profile. When unchecked, the profile will be a simple tent profile. The 

pictures in the dialog indicating the general profile shape, and the section being 
specified, change accordingly.

•• Spike  Define the temperature (default 225°C) which should mark the 
bottom of the spike phase (the final rise) of the desired profile, and its 
target slope (default 2.0°C/s). (The desired peak temperature of the 
profile is specified later in the dialog under the ‘Reflow’ section.)

•• Reflow  Define parameters for the reflow phase of the desired profile (the 
period above liquidus): the permitted range for peak temperature (default 
225–245°C), the liquidus temperature (default 217°C, for lead-free 
solder) and the permitted range for time above liquidus (default 
1–1.5 mins). If you wish, enter a single target value for peak temperature 
(default 250°C) and for time above liquidus (default 1.5 mins). If you enter 
data for time above temperature, the Reflow Results analysis of the 
predicted profile will show the time spent above the given temperature by 
each probe.

•• Line Speed  If a single line speed is specified, it will be used for all predicted 
profiles (default 60 cm/min or 24 in./min). To produce predictions based on 
a range of line speeds, check Use Optimized Line Speed and enter 
minimum and maximum values (default 45–75 cm/min or 11.8–35.4 in./min).

After clicking Next in this dialog, you will be prompted to save your data as a 
process limits file. The filename will be saved with a .RPL extension. There is 
a default directory in which files are stored, but you can browse to a directory 
of your choice.
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Generating Recipe Predictions

After setting up the process limits (see above), click  or select Easy Oven 
Setup > Recipe Predict to carry out a recipe prediction. By using data from your 
solder-paste specification, Insight will create recipes which are predicted to 
produce temperature profiles to match the solder’s preferred usage conditions. 
When a prediction has been performed, the results are displayed in the main 
Graph and Analysis Windows where further trials and analysis can be carried 
out.

Only one prediction can be open at a time. If you already have a prediction 
open, you must close it before you can start a new prediction.

In order to ensure successful predictions, unheated oven zones must 
be specified.

On starting a prediction, the Select Process Limits dialog opens:
1.	 Highlight in the list the process limits file appropriate to your recipe 

prediction. The process limits files shown for selection are those contained 
in the default directory, but you can also click Browse to locate files which 
you may have stored elsewhere. On the right of the dialog is shown a 
summary of the parameters contained in the selected process limits file, 
with a picture indicating whether the limits are for a simple tent profile or 
for a ramp/soak/spike profile.

2.	 Click OK in the dialog. The recipe prediction is then carried out.

Refining the Predictions

The predicted recipes are then listed in the Analysis Window in order of 
rank (shown by a star rating) according to the closeness of their expected 
result to the specified process limits; in calculating the recipes, the parameters 
in the limits that are given the highest importance are peak temperature and 
time above liquidus. Next to each recipe’s rating is also shown its line speed 
and the average of its oven-zone temperature settings.

To list predicted recipes in an alternative order – by descending order of line 
speed, or of average temperature – click on the relevant column header. Click 
the header a second time to reverse the order.

Highlighting a recipe in the list displays the following for it:
•• The predicted profile that the recipe is expected to produce. Marked on 
the graph are the permitted ranges for peak temperature and time 
above liquidus as specified in the process limits used. In addition, a tangent 
on the profile indicates the point of maximum slope for any probe; the 
number of the probe with this maximum slope is shown on a label adjacent.



REFLOW TRACKER	 Easy Oven Setup	 41

•• Oven settings – the set temperatures for each oven zone and the line 
speed.

•• Data analysis for its predicted profile. The full range of analysis options is 
available. The contents of the Reflow Results tab reflect what was 
specified in the process limits used, though you may use the analysis options 
dialog to add or remove results from the display. Any entries in the analysis 
grid that are out of tolerance compared with the process limits are 
highlighted in red and an alarm is registered.

Oven zone names appear in a tooltip if the mouse is hovered over a zone 
number in the Oven Settings grid.

The following control buttons are available:
Delete 
Recipe

Delete from the list any recipe you have created and do not wish to consider 
further (i.e. a user recipe – see below). If you previously saved the recipe (see 
below), it is deleted only from the list, not from disk.

Save 
Recipe

Save to disk any new or amended recipe you wish to keep. You must generate 
a new prediction from the amended recipe (see below) before you save it.

Create 
User 
Recipe

A new entry appears in the list (based on the currently highlighted recipe), for 
which you may edit oven zone temperatures (see below). User recipes are 
indicated by * next to the recipe number in the list.

Predict 
Profile

Predict the profile for the selected recipe (user recipes only) if you have made 
changes to oven zone temperatures. The new profile is shown in the Graph 
Window.

Options Opens a dialog allowing specific probes to be excluded from the maximum 
slope calculation (see above). This is useful for excluding air probes (or failed 
probes) which show a very steep rise.

To edit a recipe’s oven zone temperatures:
1.	 Select the recipe in the list.
2.	 Click  to create a user recipe based on it.
3.	 Enter new temperature and/or line-speed settings for the oven.
4.	 Click  to generate a revised profile.
5.	 If you wish, click  to save this new recipe file.

To save the prediction, click  on the main toolbar, or select File > Save, or 
File > Save As > Prediction; the profile is saved as a prediction file with a .PRE 
extension.
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Troubleshooting the Predictions
Poor predictions can be due to problems or errors in any of the components of 
a prediction. Care must always be taken when entering data or performing runs. 
Common reasons for bad predictions are as follows.

•• Invalid zone length measurements – The oven’s actual zone lengths 
and those entered into the oven file are different.

•• Setting up active/passive zones improperly – Check that you have 
correctly defined oven zones as either active (heated) or passive (unheated).

•• Entering wrong recipe settings into the oven – The oven recipe 
settings (oven-temperature set points) and the actual set points on the oven 
during the profile run are different.

•• Entering wrong line speed for the oven – The actual time spent in 
each oven zone will be different from that calculated.

•• Not allowing the oven to warm up or settle sufficiently – This will 
result in actual temperatures that are different from the set temperatures or 
greater fluctuation in temperature while the oven settles.

•• Noisy oven – Some ovens are inherently unstable or have large 
temperature differences across the belt width. Use Statistical Process 
Control (p. 27) or Surveyor (p. 43) to monitor your oven’s 
performance.

•• Inconsistent attachment of thermocouples to the PCB – The 
temperature as measured by the thermocouple is very dependent on the 
method used to attach it to the PCB.
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Surveyor
Insight Reflow Tracker Professional only.

The stability of an oven’s performance is typically monitored by recording the 
temperature profile experienced by a standard PCB (a ‘golden board’) as it 
passes through the oven – but this can be misleading, as changes in the golden 
board over time can themselves result in changes in the temperature profile 
recorded. Instead, the Surveyor system monitors the oven stability by running a 
standard instrumented carrier frame through it to gather temperature data as 
a survey profile run. The Insight software then automatically compares the 
results of this profile run with results from an existing temperature profile 
obtained when the oven was known to be operating correctly – a baseline 
survey. By this simple means, an operator can assess quickly whether or not 
maintenance or adjustment of the oven settings is required in order to maintain 
consistency. Temperature measurements are recorded by a Datapaq logger, in a 
thermal barrier, mounted on the carrier frame.

All profile-run data is saved automatically and quickly becomes a valuable 
database upon which longer-term analysis can be conducted in order to highlight 
trends in the performance of your process, and thus to identify and deal with 
potential problems before they occur. This is carried out simply and quickly by 
the Insight software using Statistical Process Control (SPC) analysis (see 
p. 49).

Setting up and using Surveyor involves the following stages:
1.	 ‌Configure your oven for optimum performance – Your oven must be 

set up correctly, and producing defect-free product. Analysis with the 
standard Datapaq Reflow Tracker system will assist in achieving optimum 
results.

2.	 ‌Conduct a baseline survey – In Insight, using Surveyor’s Technician Mode 
(see p. 47), run a temperature profile and obtain a baseline survey 
(p. 48). This will be used as the reference against which future runs will be 
compared. You then specify permissible tolerances from the baseline survey.

3.	 ‌Train operators to perform routine profiles – Using the Operator 
Mode, Surveyor will guide the operator through a profile run and compare 
the results with the baseline survey (p. 48). The operator will be given a 
simple pass/warning/fail result.

4.	 ‌Identify trends – Use SPC to analyze a series of profile runs (p. 49) and 
thereby predict future oven performance.
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The Insight online Help system explains in full the functions and use of Surveyor, 
and the process of making selections and entering data in the wizards: click Help, 
and then Contents, on Insight’s main menu; then, within Help, click on Contents 
headings and topics to expand and read them. In particular, see ‘Using Surveyor’ 

and (under ‘Data Analysis’) ‘Statistical Process Control’. 
 You may also click the Help button in any wizard dialog – or press the F1 key – to 

bring up help information relevant to that stage of the wizard.

Surveyor Hardware: Specifications and Use
Additional hardware used with Surveyor comprises:

•• Carrier frame, with sensors (thermocouple probes, p. 46) fitted. 

Carrier Frame

Chief features of the PA0878 frame:
•• Easily adjustable to fit the oven’s conveyor: width continuously variable from 
100 to 350 mm (3.95–13.7 in.).

•• Three fixed temperature sensors.
•• Carries a Datapaq DP5 logger inside its thermal barrier.

The frame will carry different models of the DP5 logger: six-channel standard 
and narrow case formats (but not super-slim) and 12-channel (only six channels 
are used). Thermal barriers currently available for use with these logger models 
(p. 11) can be used with Surveyor.

Dimensions Height1	 Width2	 Length3	 Weight4 
28 mm	 100–350 mm	 456–517 mm	 0.93 kg 
1.1 in.	 3.95–13.7 in.	 18.0–20.4 in.	 2.0 lb

1	 Height of the frame itself: 20 mm/0.8 in. above pin-chain, 8 mm/0.3 in. below pin-chain. Overall height of 
carrier-frame assembly depends on height of thermal barrier used.

2	 Remove side-plates for minimum width (see main text).
3	 Including sensors. Length is minimum when side-rails are fully extended.
4	 With sensors and side-plates attached.

Part numbers:
PA0883	 Surveyor frame PA0878 with sensor plugs PA0885 (p. 46) to fit standard 

6-channel DP5 logger.
PA0884	 Surveyor frame PA0878 with sensor plugs PA0886 (p. 46) to fit narrow 

6-channel and standard 12-channel DP5 loggers.
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The Surveyor carrier frame, with three sensors (at right) and their plugs (at left) ready 
to attach to the data logger which will lie within the frame in its thermal barrier. Side-
by-side sensor-plugs (PA0885) are shown; see text. The frame’s side-rails are shown 

partially extended and with their side-plates in place.

Preparing the Frame

The carrier frame easily adjusts to the width of the reflow oven. If your 
oven has a pin-chain, it is recommended to use this for supporting the frame; 
otherwise, use the mesh-belt conveyor. If using the pin-chain...

•• Push the side-rails in or out so that they fit on the oven’s pin-chain. The 
side-rails will then remain in position; do not tighten their clamping nuts.

•• For further flexibility in width, the side-rails are fitted with side-plates which 
may be unbolted and removed. The side-plates can be fitted at two different 
heights (using alternative fixing holes on the side-rails) to allow for variation 
in clearance above and below the frame in different ovens.

WARNING 
Take care not to trap fingers in the Surveyor frame when adjusting its width.

The thermal barrier lies within the central section of the frame or within the 
barrier-retaining brackets which extend sideways from the central section. If the 
brackets are not needed (and in order to reduce the width of the frame to its 
minimum), they can be unbolted and removed.
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Sensors

The frame has three fixed temperature sensors across its width, each sensor 
having two thermocouples – on its upper- and underside. Sensors are of two 
types, differing in the arrangement of their plugs, to suit different logger models.

Part numbers:
PA0885	 Sensor with pair of plugs fixed side-by-side, for standard 6-channel DP5 logger.
PA0886	 Sensor with pair of plugs face-to-face, for narrow 6-channel and standard 

12-channel DP5 loggers.

Fitting Sensors

Correct connection and positioning of the sensors is essential to the functioning of 
the system. The sensor-mounting brackets are marked to assist this.

•• Sensor brackets on the frame are marked 
with channel numbers (A), and each sensor 
must be connected to the corresponding sockets on 
the logger.

•• The lower sensor on each probe is marked 
by a spot at its tip (B). The upper sensor on 
each probe is unmarked.

Because of the plugs’ pin sizes, they will only fit in 
the logger’s sockets in one orientation – 

but do not force them.

Channels 1, 3, 5 are lower sensors. 
Channels 2, 4, 6 are upper sensors.

Preparing for a Baseline Survey or 
Profile Run
1.	 Connect the Surveyor frame’s sensors to the appropriate sockets on the 

logger (see above). Connection of sensors to the correct sockets is essential.
2.	 Using the Insight software, run the Baseline Survey Wizard or Operator Wizard 

(as appropriate) and follow its instructions, including resetting the logger.
3.	 When instructed, carefully place the logger into the thermal barrier and 

secure the lid.
4.	 Place the barrier assembly onto the Surveyor frame and place the frame on 

the oven’s conveyor.

The system is now ready for use.

A

B
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WARNING
It is essential to use the correct Datapaq thermal barrier for your individual process; 

see p. 11. Ensure that all dimensions of your logger/barrier/frame assembly are 
such that it will fit comfortably within the oven through all stages of the process. 

Failure to do this can cause the assembly to jam in the oven with consequent 
overheating and potentially-severe damage to the equipment. Resultant battery-

leakage, and the act of recovering the equipment, may cause skin burns and 
respiratory irritation.

REMEMBER TO. . .
Ensure that the carrier is always adjusted correctly, with the two side rails set at the 

correct width for the oven’s conveyor and parallel with each other.
Always allow adequate cooling time for the carrier, thermal barrier and sensors 

before further profile runs.
Always ensure that the sensors are plugged into the same thermocouple channels 
for every profile run and that they are the same as those used for the baseline 

survey. Failure to do this will invalidate the results.
Ensure when conducting profile runs that the oven settings are the same as those 
for the baseline survey. Failure to do so may result in false alarms. This applies not 

only to line speed and temperature settings, but also (in ovens where it can be 
changed) to the convection level.

OPERATOR AND TECHNICIAN MODES
Reflow Tracker Professional is run in one of two different modes – Operator or Technician 
– selected at startup.

Operator Mode
A simple step-by-step Operator Wizard guides the oven operator through a basic profile 
run, assessing the oven’s performance against a pre-existing baseline survey. No other aspects 
of the Insight software are visible to the Operator. The technician can control access to the 
Operator Mode, and set options for the Operator Wizard to simplify its use for the operator.

Technician Mode
This mode is used to create a baseline survey for an oven. It also gives access to the full 
functionality of Insight, including:

•• Extensive data analysis options.
•• Process-parameter adjustment.
•• Use of telemetry.

You may password-protect use of Technician Mode: on Insight’s main menu, select 
Tools > Options > Surveyor Technician Mode.

To change between Operator and Technician modes, Insight must be closed and restarted. 
Alternatively, run Insight a second time and open another mode to have Operator Mode and 

Technician Mode running simultaneously.
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Running a Baseline Survey and 
Setting Tolerances
Running the Baseline Survey Wizard in Technician Mode (see box) allows 
you to perform a baseline survey of a correctly functioning oven with given 
heater settings (defined in a recipe), thereby establishing an ideal temperature 
profile for a given process and defining limits – tolerance bands – within 
which the oven’s performance must fall; limits can be defined to create either a 
single tolerance band or two bands – an inner and an outer.

To run the wizard, click   or   on the Insight toolbar, or select File > New > 
Baseline Survey from the menu bar. The wizard guides you through the whole 
process, but note especially the following.

•• After setting the oven temperatures, it is essential to wait until the oven 
has stabilized at these settings before proceeding.

•• Take care when defining the tolerance band(s): too narrow a band will 
result in many false alarms during subsequent comparative profile runs, and 
too wide a band will allow the process to drift too far from the ideal before 
an alarm is produced. There are two key aspects to consider.

○○ If no oven was specified at the start of the wizard, the tolerance band will 
apply to the entire baseline survey data. Thus it is then necessary, when 
defining the tolerance band, to specify the start and end points of the 
band in order to avoid analyzing irrelevant data collected before the 
Surveyor assembly enters the oven and after it has left it.
○○ Once the start and end are defined, the tolerance band automatically 
created by the software can be modified manually as shown in the wizard. 
This may be advisable (e.g.) in areas of the oven where control is less 
critical (such as the entry hood, or the end of the cooling zone) and the 
tolerance band can thus be locally widened.

Performing a Profile Run
Profile runs to assess the oven’s performance on a regular basis will normally be 
carried out simply by running Insight in Operator Mode (see box, p. 47), 
though the operator’s role can also be carried out in Technician Mode by using 
the Operator Wizard (click   or   on the Insight toolbar, or select File > 
New > Profile Run from the menu bar).

The wizard guides the oven operator through a basic profile run, assessing the 
oven’s performance against a pre-existing baseline survey. This involves:

•• Preparing the logger for a profile run.
•• Downloading the data to the PC after the run.
•• Receiving a pass/warning/fail notification of oven performance.
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•• Saving the results and displaying them (graphically and numerically); they can 
also be printed.

WARNING 
Never carry the Surveyor assembly by holding the attached thermocouples. This can 

lead to injury by dropping the equipment onto your body, and may damage the 
equipment itself.

On removal from the oven, the assembly, including logger, will be hot enough 
to burn skin – even though its temperature will not be apparent.  

Use protective gloves.

The operator will be given one of the following clear results in a ‘traffic lights’ 
display:

red – Part of the profile falls outside the tolerance band (or, if two tolerance bands, 
outside the outer). The production manager should be informed immediately.

yellow (only if two tolerance band are defined) – Part of the profile falls outside the 
inner band but none of it is outside the outer band. The oven may be drifting out of 
specification.

green – The whole profile falls within the tolerance band (or, if two tolerance bands, 
within the inner band).

Surveyor Index

If the profile run has been performed in Technician Mode, the downloaded 
results and analyses will be displayed graphically and numerically (they can also 
be displayed in Operator Mode, if this has been enabled by the technician).

A key feature of the results is the Surveyor Index, which gives a measure of 
the overall amount by which each probe’s profile-run data differs from the 
baseline survey. It is calculated as the average (multiplied by 10) of the absolute 
differences in temperature between baseline survey and profile run for each 
data point. Surveyor Index figures are given a positive value if the profile-run 
data averages higher than the baseline survey, and negative if lower than the 
baseline survey.

Trends and Predictions with SPC
The main benefit of using the fixed sensors of the Surveyor system is that they 
provide consistent and comparable data on which subsequent Statistical Process 
Control (SPC) analysis can be conducted so that trends in the data can be 
identified and future oven performance predicted.
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For an alternative approach to identifying trends, using SPC on normal Insight 
paqfiles, see p. 28. Note that temperature profiles obtained using the Surveyor 

system will not match normal Insight paqfiles obtained from an instrumented PCB. 
The Surveyor sensors are designed to yield highly repeatable results enabling reliable 

SPC analysis to be conducted on the resultant dataset.

Analysis is carried out using the SPC Wizard: click   on the Insight toolbar, 
or select File > New > SPC from the menu bar. Data from all profile runs 
associated with a particular baseline survey is automatically stored together in 
the same folder, so selection and analysis is made quick and easy. The process is 
fully described and discussed in the online Help (under ‘Data Analysis’ see 
‘Statistical Process Control’).

SPC analyzes the profile-run data according to specified acceptable temperature 
limits, and by default these are taken as the (outer) limit specified when creating 

the baseline survey. In the final stage of the wizard you may, however, specify 
alternative limits, but note that this changes the values of USL and LSL used in the 

calculation of capability statistics. For a full explanation of the calculation of Cpk, Ppk, 
etc., see ‘Statistical Process Control’ in the online Help.
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Troubleshooting
For problems in communication between the logger and the PC and 
for logger download error messages, see the ‘Troubleshooting’ chapter 
of the dedicated User Manual for your logger.
For process problems revaled by temperature profiles, see p. 26 for 
reflow and p. 35 for wave solder.
To troubleshoot problems with predictions in Easy Oven Setup, 
see p. 42.

Checking the Data
If you suspect that invalid data may have been introduced into your 
temperature profile (paqfile), perhaps by damaged thermocouples (see below), 
select the View Data tab in Insight’s Analysis Window to view the raw data as 
downloaded from the logger. The various types of invalid data which may be 
contained in a paqfile are shown in the analysis grid as follows.
*OC*	 Open circuit. (Will occur if recording starts before thermocouples are plugged in.)
*NA*	 Telemetry data not received. Check antenna connectors.
*LO*	 Temperature measured was below the range of the logger.
*HI*	 Temperature measured was above the range of the logger.
***	 Calculation cannot be performed (not necessarily because the data are invalid). Does 

not appear in View Data analysis mode.

Typical causes of invalid or interrupted data are:
•• Damaged thermocouple cable.
•• Thermocouple becoming detached from plug/logger.
•• Faulty connection at thermocouple’s hot junction.

Readings which are inconsistent with those of other thermocouples may be 
caused by a short circuit (see below). The thermocouple concerned must be 
replaced.

Open circuit readings can occur during a profile run if a thermocouple 
becomes damaged. The logger will then continue sampling on that channel, but, 
by default, an alarm will be registered. For further details of such alarms, or to 
disable the alarm, select Tools > Options > Run Alarms.

Thermocouples with an intermittent open circuit may produce spiky, erratic 
profiles. Note that spikes are inevitable when thermocouples are disconnected 
from a running data logger.
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Testing the Logger and Thermocouples
Although thermocouples are generally robust, they can be damaged during 
handling. Use the following procedure to confirm the operation of logger and 
thermocouples after installation. Note that this test is not an alternative to 
calibration (see the dedicated User Manual for your logger), but will highlight a 
malfunctioning logger or faulty probes and thus avoid a wasted profile run.

Do one of the following:
•• With a full set of thermocouples attached to the logger, and the logger 
connected to a PC running Insight, open the Logger Reset dialog or the 
Diagnostic section of the Communications Setup dialog; this shows current 
probe temperatures – or...

•• Set up the system as if to monitor a profile run using hardwired telemetry 
(see the dedicated User Manual for your logger), and note the temperatures 
registered by the thermocouples as they are displayed in Insight – or...

•• To test the thermocouples alone, use a digital thermometer (of a type to 
match the thermocouple type) and attach it to each thermocouple in turn.

Proceed as follows.
1.	 Note readings first at ambient temperature: thermocouples registering no 

data in Insight, or an open circuit with a digital thermometer (*OC* in the 
Communications Setup dialog), may be broken. Inconsistent readings may 
indicate an intermittent short circuit.

2.	 If a satisfactory ambient reading is recorded, apply heat to the thermocouple-
tip via fingers or other heat source. An increased temperature should register.

○○ If the reading does not change, the thermocouple is short circuit or has 
other damage and must be replaced.

○○ If the temperature shows a decrease, the thermocouple connections are 
reversed.

3.	 Confirm correct operation at 100°C by placing the thermocouple-tip in 
freshly-boiled water.

4.	 Replace any damaged thermocouples and test again.

Datapaq Service Department
If you cannot resolve your problem, please contact your nearest Datapaq 
Service Department at Fluke Process Instruments. For contact details, see 
www.flukeprocessinstruments.com – or email as follows:

Europe, Asia (except China), Africa, Australasia – datapaqservice@
flukeprocessinstruments.co.uk

China – service@flukeprocessinstruments.com.cn
Americas – auto-rma-us@fluke.com
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The user may easily download and email key diagnostic information to 
Fluke Process Instruments:
1.	 Connect the logger to the PC with Insight running.
2.	 Select Logger > Setup > Advanced, or Help > Service.
3.	 Select a name and location for the downloaded file, and a destination for the email. 

The file created is accessible to Fluke Process Instruments but is not designed to 
be opened by the user.
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